iPhone Bugs

Discussion in 'iPhone Tips, Help and Troubleshooting' started by longofest, Jun 30, 2007.

  1. brasscat macrumors 6502

    brasscat

    Joined:
    Jun 9, 2007
    Location:
    Dallas, Texas
    #26
    Sometimes the e-mail message headers get out of sync with the body.

    The browser seems to crash when I have four or more pages open.

    The device puts out a lot of interference when accessing the ATT network (shielding issue maybe?)
     
  2. elistan macrumors 6502a

    Joined:
    Jun 30, 2007
    Location:
    Denver/Boulder, CO
    #27
    Not at this time - I haven't brought it to Apple's attention yet. Need to go down to one of their stores and show them.
     
  3. eab6287 macrumors newbie

    Joined:
    Jul 2, 2007
    #28
    Several bugs...

    I love the iPhone overall, but have noticed the following problems:

    1. As people have mentioned, the iPod will crash when browsing with Safari. I've found additionally, however, that mine at least seems to crash only immediately after I try and zoom (by pinching in). I can browse for quite a while with steady music as long as I don't zoom.
    2. Again, this is already mentioned, but Safari seems to crash randomly very frequently for me. No error message is given, it just closes.
    3. Safari quits when an email is received. I realize that this is probably on purpose; iPhone is notifying you that you have received a message. However, when I return to Safari, I am often logged out of web pages and have to re-enter my login and password information. This is particularly annoying as iPhone doesn't seem to be able to remember login information or passwords.
    4. Problems with the orientation sensor; my iPhone is not at all good at telling whether it is held vertically or horizontally. It works only about 40-50% of the time. I can force it to work by making forceful, sudden movements, but this shouldn't be necessary.
    5. Problems with certain web interactions; i.e. setting status on Facebook - clicking in the field to set your status shows a text entry box for about a half second and then it disappears before you can enter any text.
    6. SMS Text application is slow to launch (takes about a full 5 seconds on my phone)

    If any of you have found solutions to any of these problems or are having the same issues, please let me know (especially number 3, 4, & 5)
    Restarting the phone has helped fix the safari crashes, but only for a while and then the issues reoccur.

    :confused:
     
  4. herrade macrumors newbie

    Joined:
    Jul 1, 2007
    #29
    Loses Network when Syncing

    I got a "No Service" indicator in place of the signal strength bars the last time I put the iPhone in the cradle and a sync began. Powering off completely (not just putting to sleep) brought the network back to life.

    ATT rep had no idea why this happened.
     
  5. randgalt macrumors newbie

    Joined:
    Jun 22, 2007
    #30
    Me too. I looked on Apple's site. I assume they're reading the various blogs and know about this, but it would be nice to have a way to let them know about it.
     
  6. eagle33199 macrumors member

    Joined:
    Mar 13, 2007
    #31
    This is a function of how mail clients and gmail work. First, the mail client gets a message - regardless if it's been read on another client it'll show up as new. Try it yourself - close your client on your computer, log into gmail through your web browser, send yourself an e-mail, read it, then open your client back up on your computer. it'll show up as new!

    Another one of the annoying problems with gmail is whole sent e-mails in the inbox thing. If you send an e-mail from the gmail website, it'll show up in your inbox on any client you have set up to download your e-mails!


    On to my bug... I first synced my music, and everything went fine. Next i decided to sync my pictures. Selected all of them, and i only got the "last roll" from iPhoto. no error message or anything. Played around a bit, and eventually found out that if i selected a smaller subset of albums, they would all appear. It seems that rather than tell you your iPhone is full, it just stops when it can't download an entire album.

    The key to the whole thing for me was that the "last 12 months" album was second in the list (by default), and was huge. Moving it to the bottom allowed most of the other smaller albums to download just fine, until i could actually see that the phone was full (instead of the 1.5 gigs that were open in the previous attempts).
     
  7. eagle33199 macrumors member

    Joined:
    Mar 13, 2007
    #32

    i thought the same thing at first about the talk volume... have you tried turning up the volume (using the rocker switch on the left side of the phone) while you're in a call? it did wonders for me!
     
  8. jbellanca macrumors 6502

    Joined:
    Jul 2, 2007
    #33
    Three times now this has happened with 5 bars of signal. The signal will totally drop and the phone says "no signal" - just dropped it entirely. Then I reboot the phone, and it says "no sim". I reboot again, and same message. Reboot again, and it locks in 5 bars of signal, no problem.

    Today is the first time this has happened - it's been perfect before now. Anyone else having this issue at all? Sounds like it could be hardware or software related.
     
  9. yakface macrumors newbie

    Joined:
    Jul 2, 2007
    #34
    In the 'phone' application, when creating a new contact if you enter all the information and, before saving the new contact, you try to take a photo to add to the contact page, the application quits and dumps you back to the home page and all the information you entered is lost as that contact is not saved.

    This happened to me twice. A work-around it to enter the contact information *first* and save the contact. Then go back and 'edit' the contact and take the picture you want to add.
     
  10. brasscat macrumors 6502

    brasscat

    Joined:
    Jun 9, 2007
    Location:
    Dallas, Texas
    #35
    This has happened to me as well.
     
  11. dy111 macrumors newbie

    Joined:
    Jun 27, 2007
    #36
    has happened to me as well! Im actually on my iphone right now searching to see if this happened to anyone else. Its happened twice, and i dont like it!:mad:
     
  12. bitty417 macrumors member

    Joined:
    Jul 2, 2007
    #37
    06 BMW 3 Series -- Same problem. When using Bluetooth audio cuts out for a second or two at a time.

    Tried it this afternoon in my wife's 07 BMW X3 - same thing.
     
  13. jlanuez macrumors 6502

    Joined:
    Sep 13, 2006
    Location:
    USA
    #38
    Sounds like you are on a Windows PC?

    When I sync with my Mac (when photos are in the roll), iTunes AND Apple's Aperture open and "just work" by each doing what they need to do at the same time, correctly. I did shut the (auto)Aperture feature off as I don't want it opening every-time I dock the iPhone.
     
  14. varscsak macrumors newbie

    Joined:
    Jun 30, 2007
    #39
    I would concur with this. I'm definitely not getting battery times like good old Walt Mossberg from WSG did.

    Lon
     
  15. brwnbooger macrumors newbie

    Joined:
    Jul 2, 2007
    #40
    Hardware design flaw - headphone jack

    Did anyone else notice that the headphone jack is irregular. The hole is very deep and standard headphones did not fit into the hole (I tried 5 kinds). For all the headphones the insulation around the pin prevented it from fitting in the headphone jack. Did apple put out any special converters for this? I remember steve saying that the headphone jack is a standard 3.5mm at macworld..... it is 3.5mm but sure isn't standard if it can't fit any headphones other than the ones that come with the iphone. :mad:
     
  16. jbellanca macrumors 6502

    Joined:
    Jul 2, 2007
    #41
    Didn't think I'd find a bug, but I did. Here it is:

    Apparently the first DNS server for my ISP went down. My laptop's smart enough to fall back to the secondary DNS server. Although a second one is listed on the iPhone, it apparently won't use it, and Safari times out because the first DNS server was down. I switched the 2nd one with the 1st one in the wireless setup on the iPhone and it's working. It shouldn't obviously happen very often, but Apple needs to fix this in the future.
     
  17. Jsimon9633 macrumors regular

    Joined:
    Jun 26, 2007
    #42
    Agreed. I am pretty sure they are looking at all these bugs and planning a software update. I expect that from Apple especially after the activation snafus.
     
  18. ryanneves macrumors newbie

    Joined:
    Jul 2, 2007
    #43
    Signal Issues

    I too have had single jumping issues from full to no service in ATT "Great" service areas....hopefully someone will own up and fix this one.
     
  19. Jsimon9633 macrumors regular

    Joined:
    Jun 26, 2007
    #44
    Today I found another bug, I tried to send email from my iPhone through Reply from Yahoo and it crashed, not only did it crash but it seemed that the next time I entered the mail app it was frozen for like 5 seconds.

    Strange!!
     
  20. johnnybluejeans macrumors 6502

    Joined:
    Jan 16, 2006
    Location:
    New York, NY
    #45
    Are you walking when you have this problem? I've noticed that if there is a lot of other movement going on (walking, running which causes your hands to bounce a bit) the orientation sensor has a hard time picking up rotation. Otherwise, at a standstill I've never had any problems.
     
  21. johnnybluejeans macrumors 6502

    Joined:
    Jan 16, 2006
    Location:
    New York, NY
    #46
    You can set up a filter in gmail (by logging into gmail.com) to delete any emails where the "From:" field matches your email address. This will keep the email in your sent folder on your iPhone or Mail at home, but it will prevent it from showing up in your Inbox.
     
  22. johnnybluejeans macrumors 6502

    Joined:
    Jan 16, 2006
    Location:
    New York, NY
    #47
    I've noticed that if you try to position the cursor using the magnifying glass in text that is near the top of the screen, the magnifying glass will be off the screen. Anyone else have this issue? It is rather annoying because generally when I'm positioning the cursor the text is near the top of the screen because the keyboard is taking up the bottom.
     
  23. eagle33199 macrumors member

    Joined:
    Mar 13, 2007
    #48
    Another small problem... I have about 1 gig of photo's on my iPhone (at least, i did last night after the last time i synced at home). Anyways, i've been showing it to a bunch of people here at work and the battery was getting a little low, so i plugged it into my computer here to recharge. I'm not sure at exactly what point this happened, but now when i go to look at my photo's, it comes up empty! According to iTunes on this computer, there's still 1.11 gigs of photos on the iPhone. I did have to "abort" the initial syncing, so that may be part of the problem... it's now set up to never sync this iPhone from this computer, so hopefully when i sync back at home tonight it'll all get straightened out!
     
  24. getoffoil macrumors newbie

    Joined:
    Jul 3, 2007
    #49
    safari crashes when visiting

    ever time I try to go to homedepot.com the page almost finishes loading and the crash! back to the main menu. Anyone else?
     
  25. footOdorProblem macrumors newbie

    Joined:
    Jul 3, 2007
    #50
    Vertical status bar in portrait mode

    Visit apple.com/iphone in Safari.
    Play the Finger Tips video or any other video that works in Safari.
    While in the embedded video player, put the phone in landscape mode.
    Click the 'Done' button at the top-left corner.
    Quickly move the phone to portrait mode before the web page reappears.
    The status bar will now be on the left or right hand side (depending on which landscape orientation you were in).
    The correct status bar position will be restored when you press Home.
     

Share This Page