iPhone cal events off by an hour

Discussion in 'iPhone' started by Cave Man, Nov 9, 2007.

  1. Cave Man macrumors 604

    Cave Man

    #1
    For some reason, my iCal events on my iPhone are one hour later than my iCal events from the sync'ing mac. My iPhone's time is correct, it's just that the events are off by an hour. Any idea what might cause this?
     
  2. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
  3. Cave Man thread starter macrumors 604

    Cave Man

    #3
    I don't see how to set a time zone on the iPhone. Both the Mac and iPhone agree on the time, it's just that the sync'ed iCal events are behind by an hour on the phone. Weird.
     
  4. cwedl macrumors 65816

    cwedl

    Joined:
    Jun 5, 2003
    #4
    When this happens on Windows Machines it seems to be with Day Light Savings. Have a look at that
     
  5. southyde4eva macrumors newbie

    Joined:
    Nov 9, 2007
    Location:
    Dallas, TX
    #5
    I had the same problem. It does have to do with the time zone setting on the phone. On your iPhone go to Settings> General> Date & Time. Under the Calendar section you should see a place where you can adjust the Time Zone settings.

    Adjusting these settings solved the problem for me. Hope this helps!
     
  6. Cave Man thread starter macrumors 604

    Cave Man

    #6
    Well, that did the trick. I wonder why it only happened after the time change, since it was fine before.

    Thanks for the help.
     
  7. southyde4eva macrumors newbie

    Joined:
    Nov 9, 2007
    Location:
    Dallas, TX
    #7
    No prob. I also thought it was weird that I only had the problem after the time change. Like you, everything was fine before. :confused:

    Glad I was able to help.
     
  8. davisfilms macrumors newbie

    Joined:
    Sep 9, 2009
    #8
    Mobile Me 1 Hour Off

    I had the one hour off ical events on my iphone 3GS too. I sync over mobile me. I dug around and here's what fixed it: Settings>Mail, Contacts, Calendars>Scroll all the way down and make sure the time zone is correct. I changed that and it fixed my cal in an instant.
     

Share This Page