iPhone calendar event dates are days different than MobileMe and iCal - any ideas?


macrumors newbie
Original poster
Jun 13, 2010

iPhone 3GS, version 4.0.1
Macbook pro - Mac OS X 10.6.4

[EDIT: to include Short version - since I see people are looking at this, but not commenting. Thought it was probably too much to read.]

Syncing between mac and mobile me is fine. iPhone calendar has all entries but items showing on wrong dates. (ex: items scheduled on 7/29 and 7/31 are displaying on 7/26) If I go to edit the event, the date is correct.
Any ideas on how to fix? Have tried several things (see in long answer). I'm thinking I may have to go back to my last backup before I started using mobileme (when iPhone and mac were both fine). Agree/disagee? Any other ideas?

[Longer version]
I've searched and tried several tips on syncing issues, but no one seems to be having the same issue I am and those solutions don't seem to help so I'm turning to the wisdom of the forums as hopefully someone will have a suggestion for me to try because this is driving me CRAZY!

I have a somewhat new Macbook pro and signed up for a trial MobileMe account last week. For a few days, everything synced fine between Macbook/MobileMe/iPhone. Then, I started getting duplicate events only on my MobileMe calendar. The next day, these duplicates started showing up on my iCal. iPhone was fine at this point and new events added to the iPhone calendar still showed up on MobileMe calendar and iCal.

To get rid of the duplicates (they seemed to be multiplying every time I logged in to MobileMe) I exported iCal when it was correct (and still have that saved so I'm open to trying things) and then stopped everything syncing (turned to manual sync on Macbook and deleted MobileMe profile on iPhone). MobileMe was correct at this point (I deleted all of the duplicates) so I re-synced to iCal and replaced the iCal entries with what was on MobileMe. Then to get the iPhone on the same page, I re-added MobileMe profile to iPhone. I selected don't merge and replace entries when adding MobileMe again. (Contacts and other items sync fine.) iCal and MobileMe are now fine, but the iPhone is all messed up!

All my events are showing on my iPhone now, but are days different from iCal/MobileMe! I have items that are supposed to be on Thursday 7/29 and are showing up on Monday 7/26 on my iPhone and items that are supposed to be Saturday 7/31 showing up on Monday 7/26 (with the same Thursday events)!

This isn't a time zone thing from what I can tell. (Time zone support is off in both MoblieMe and iCal - although I tried turning them both on and removing/reloading MobileMe profile from iPhone to see if that helps.) iPhone is set to automatically detect time/date (and displays correct day) and both iCal and MobileMe know what day today is.

When I click on an event stored on my iPhone the correct day/date is displayed in the event details, making this even more baffling to me.

I have no idea what could be wrong.
Does anyone have any ideas or is this so screwy that I need to try some sort of apple support? (and if you think apple support is needed, what type would you recommend? Chat, phone, or do I need to try the genius bar?)


macrumors newbie
Aug 18, 2010
I had this problem too until a few moments ago. Go to your account setting in mobileme through the web. See if your timezone is different. Mine was set to Cupertino. Then, when you enter a new event make sure the time is consistent with the way settings show them. I have mine set to military time but when I entered 1400 it corrected it to 1:40. When I enter 14 it changes it to 1400. It's quirky but it seems to be working now.


macrumors 6502
Apr 11, 2010
Did you try calling MobileMe support? You pay for this stuff, you might as well use up some of their technician time.

In any case, don't worry too much about it. I've recently migrated my calendar from MobileMe to Google in preparation to not renew MobileMe, and push calendar syncing works perfectly (along with push contacts and email).


1: In iCal, go to File>Export>Export

2: In Google Calendar, go to Calendar Settings>Calendar>Import

3: Configure Google Sync on your iPhone
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.