iPhone Calendar Time Zone Issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by borg1of2, Jul 12, 2007.

  1. borg1of2 macrumors member

    Jun 27, 2007
    I have noticed that the Calendar on my iPhone after synching with my PC, Outlook on a Windows XP machine, where the originator of the calendar event set the meeting in their timezone, i.e. CST and I'm in EST. Once I get the meeting in Outlook it adjusts the time to the correct time for my timezone.

    However, it appears that iPhone is listing the meeting notice based on the originator's time and doesn't do any timezone adjusting.

    Has anyone else noticed or figured out how to resolve this?

  2. mitchlandry macrumors member

    Jun 14, 2007
    I haven't used the meeting syncing yet, but have checked the time zone on the phone. Mine was blank and had to set it under the settings.
  3. borg1of2 thread starter macrumors member

    Jun 27, 2007
    Thanks. I checked there and it was blank. That is an interesting data entry screen. I had to enter New York as Tampa FL did come up as city. Not sure what they want you to do, I guess entering any city that is your timezone works.

    I think this may explain what happened, but somehow my meetings got messed up and what was actually wrong was the PC. I'll re-synch to see what happens.
  4. kramer147 macrumors newbie

    Oct 14, 2007
    time zone support seems to be the key

    in my calendar i usually input events without respect to time zones. for instance if i am flying at 310pm from the central time zone to the mountain time zone landing at 430pm, i will input an event as "flight to xxx" with the time "310-430". this seems to be the best method of avoiding the phone trying to compensate for time zones and ultimately screwing up my times. BUT if i make an event while i'm in the mountain time zone and then look at it while i'm in the central time zone it likes to shift everything an hour ahead because it thinks my events are for the mountain time zone and need adjustment. the simple fix i have found for this is turning on time zone support first in ical and manually setting your most frequently used time zone to stay static and then under time and date preferences for the iphone manually set your calendar time zone to the corresponding one you chose in ical. this forces the phone to keep your times the same no matter what the cell phone signal tells it about what time zone it is in. seems to be the most fool proof method of not having your phone switch your times and make you miss a flight!!!
  5. xtech macrumors newbie

    Aug 9, 2005
    Time zone flaw

    I've had problems with the "auto" settings mode for timezone. It doesn't work, or at least not properly. I go from one time zone to another and it stays in the old timezone until I set it manually. This is a flaw in the iPhone 4g that I didn't have in my iPhone 3g. Any other comments?
  6. RaZaK macrumors regular


    Jul 13, 2008
    Still a problem with iPhone 4...with a twist

    I sync my Calendar info with my company's Exchange Server. My meeting organizers are in the same time zone as me (EST).

    When I accept a meeting, it shows up in the Calendar as being one hour earlier than it is supposed to be in my Calendar. So, if the meeting should be at 9:30, it is listed as 8:30 in the iPhone Calendar. I get notifications for the meeting starting at 8:30, and as 9:30 approaches, I get meeting notifications again.

    Very strange. However, if I do follow the remedy of explicitly setting my time zone in the Calendar settings screen.

    Has anyone else seen this with the latest version of iOS4, and has anyone resolved it?
  7. martinmartin macrumors 6502

    Jun 5, 2007
    I'm also having this problem.

    Was on the west coast all summer. Just got back to the east coast.

    Now, as I get calendar invites, the times are 3hrs off.

    My phone is acting like I'm on the west coast. For example, if someone sends and invite for an event from 5-8, my calendar lists it as 2-5. Not good.

    Hoping someone has a fix.

    Edit - well i fixed it. Looks like i never changed the time zone on the phone when i came back to the east coast. went to settings, mail/contacts/calendar, time zone support...
  8. TheHof macrumors newbie

    Oct 26, 2010
    Problem solved

    I was having this issue for a while and could not figure it out. The time zone support in my iPhone 4 was turned on to pacific while im mountain. I switched that and now everything is normal! Thank you
  9. kpbarbee macrumors newbie


    Feb 2, 2011
    Time Zone Support Setting Doesn't Work

    Hi there--
    I have the same problem as I travel a lot internationally. I changed my time zone and when I got back to Singapore, it's stuck in the US Pacific Time Zone. I changed the time zone support back to Singapore, it displays "Singapore," but when I enter an appointment in the calendar, it displays the US time on my Singapore Calendar--I'm using an iPhone 4 (4.2.1)

  10. penter macrumors 6502a


    Jun 15, 2006

    I'm having the same issue as the person above me. please help!

    edit: here's the solution.
  11. bill2p macrumors newbie

    Mar 7, 2011
    I almost missed a flight in Bangkok, because I had entered in the flight time in Berlin and iCal/iPhone Calendar changed the time to agree with the time zone of my current location. Thankfully I thought to have a look at the airline's itinerary where I noticed the error, instead of relying on iCal/Calendar. I couldn't figure out a solution I could absolutely trust, so I now enter "BKK to TXL 11:40" as the name of my appointment. Would it help if I entered in the location ie "Bangkok" in the "Location" field?
  12. penter macrumors 6502a


    Jun 15, 2006
    the solution is stated right above you.
  13. clm1k1k macrumors newbie

    Mar 9, 2011
    Similar problem - fixed


    I had a similar problem after traveling to/from another timezone. I changed the settings as described below and it fixed my problem.


  14. iheartnola macrumors newbie

    Apr 8, 2011
    got it!

    I think I got it... go to Settings --> Mail, Contacts, Calendars --> scroll down all the way to Time Zone Support --> turn Off. Good luck!

Share This Page