iPhone call answered, Mac keeps ringing

Discussion in 'OS X Yosemite (10.10)' started by allenawatson, Sep 22, 2014.

  1. allenawatson macrumors newbie

    Oct 22, 2011
    Using Yosemite beta and iOS 8, when I receive an incoming call on my phone and answer it on the phone, it keeps ringing endlessly on my Mac until I go to the Mac to silence it by clicking Accept or Decline.

    Is there some way I can make the Mac stop ringing when I answer the phone? Or must I disable the handoff feature on my phone (not desirable)?
  2. Lancetx macrumors 68000


    Aug 11, 2003
    I noticed my girlfriend's iPad was doing the exact same thing over the weekend. She finally just turned off the Handoff feature until they push a fix.
  3. lulla01 macrumors 68020


    Jul 13, 2007
    All my devices usually keep ringing for a few seconds after i pick up a FaceTime or call.
  4. allenawatson thread starter macrumors newbie

    Oct 22, 2011
    Yeah, but even though I answer on the iPhone, for me the ringing never stops until I go to the Mac screen and click on the notification there. As another reply suggests, I'm turning off Handoff until this gets fixed.:(
  5. Shadowbech macrumors 68040

    Oct 18, 2011
    Yea I noticed my iPad doing this too when I answered the phone on my phone.
  6. Julien macrumors G3


    Jun 30, 2007
    A little related. I can hear on my Mac but I can't be heard. Mic is working for everything else and even Input Level shows a signal in System Preferences.
  7. mrwfive macrumors newbie

    Sep 22, 2008
    Same issue.

    I'm having this same issue. It seems that no matter what I do in my settings, the *only* mic that will currently work is the Macbook Pro's internal mic. I've spent a lot of time trying to get various external mics to work, and I cannot.
  8. dhjdhj macrumors newbie

    Sep 3, 2008
    When I answer my iPhone call on my Mac, I continue to hear the ringing tone on my Mac, for the entire duration of the call. This has happened twice now.

    Anyone know how to fix this?
  9. ijha macrumors regular


    Aug 20, 2009
  10. Benzion macrumors newbie

    Dec 18, 2014
  11. DamnDJ macrumors regular


    Feb 17, 2003
    Denver, CO
    Same here. I just figured the Mac remains ringing as some sort of notification until you dismiss it. If it's working as intended, that's a pretty annoying "feature".
  12. borostef macrumors 6502


    Feb 10, 2012
    Zagreb, Croatia
    My Mac keeps on ringing for ten or fifteen seconds after I answer a call on my iPhone... Then it stops... Still annoying, the person I'm talking to usually asks: "What's that ringing in the background?" :)
  13. jozeppy26 macrumors 6502


    Jul 8, 2008
    St. Louis
    Same here. Phone calls scare the crap out of me now too, lol. My macbook hooked up to desktop speakers, my iPhone, and my iPad all ring different ringtones at the same time.
  14. Davidglenn macrumors member


    Dec 3, 2014
    I have the same issue. Even after I have finished the phone call and hung up on my iPhone the MBP still keeps ringing. I have to go to the MBP and hit decline to stop the ringing.
  15. borostef macrumors 6502


    Feb 10, 2012
    Zagreb, Croatia
    Tell me about it... The first few phone calls after this feature was introduced were amazing, iPhone, two Macs and two iPads all ringing at the same time, with their own ringtones... Since then I have disabled phone calls on my Mac Mini because it is hooked up to desktop speakers and I can't risk a trip to the hospital every time my phone rings... :)
  16. Healz macrumors newbie

    Mar 29, 2012
    iPad keeps ringing

    Same thing here. However, my Macbook Pro stops ringing after I pick up the call on my iPhone, but my iPad Air 2 continues ringing. I don't know how long it would have kept going; I just decided to hit the down volume key to silence it. So annoying. I hope Apple fixes this soon! :(
  17. luckylisp macrumors 6502

    Feb 2, 2006
    NY state
    Same problem here. When I answer a call on my iPhone 5s, my iPad continues to ring for about 30 seconds. Very annoying.

Share This Page