iphone cannot send mail - The senders address was invalid

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fameadvance, Aug 5, 2008.

  1. fameadvance macrumors newbie

    Joined:
    Jul 19, 2008
    #1
    Is anybody else having issues with yahoo small business mail where they can receive emails but when sending get a pop up saying “Cannot sent mail The senders address was invalid”

    I have tried everything that I can think of, it driving me crazy. I tried deleting the account and re-entering the info, I’ve tried changing the ports, turning off SLL, and a password reset and still it doesn’t work.

    I have spoken with yahoo and they assure me my account settings are correct, and are blaming apple. They said the fact that my imac is working fine with the same settings proves it the fault of the iphone.

    Can anybody please help, im tearing my hair out.
     
  2. fameadvance thread starter macrumors newbie

    Joined:
    Jul 19, 2008
    #2
    I have the iphone also set up with mobile me and that account sends email without any issues. Anybody know whats up with yahoo?
     
  3. fameadvance thread starter macrumors newbie

    Joined:
    Jul 19, 2008
    #4
    Thanks Moi

    I read through all the post and eventually found this solution.

    1.Settings
    2.Mal, Contacts, Calendars
    3.Click on the pop account you are having issues with
    4.Click SMTP under "Outgoing Mail Server"
    5.IS the Primary Server your Pop acct? and is it on?
    6.Click on it
    7.I had to put in my user name and password where it said optional
    8.For me SSL is OFF
    9.Authentication is set to password
    10. Port 25

    This worked for me Thankyou
     
  4. Dott macrumors newbie

    Dott

    Joined:
    Aug 1, 2008
    Location:
    Australia
    #5
    This fixed the problem for me, it seems iTunes doesn't sync the mail account password with your account settings.
     
  5. webbernet macrumors newbie

    Joined:
    Aug 16, 2008
    #6
    for those who still have problems.

    Make sure you have set the "Description" for your account to your full email address.
    do a hard reset.

    if still doesn't work. delete the account, create it again and don't change the Description as iPhone uses the email by default.
     
  6. MrCyberdude macrumors newbie

    Joined:
    Mar 5, 2009
    #7
    This also worked for me.

    I kept SSL ON
    Just added the username and password.

    MrCyberdude
     
  7. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #8
    worked perfectly for me!!!!


    FINALLY!


    Thanks bro.
     
  8. LebEttex macrumors newbie

    Joined:
    Aug 15, 2009
    #9
    "Optional" fields

    Thanks so much Fameadvance and everyone - I haven't been able to send emails from my iPhone for months, and you've cured the problem. I'm very very grateful.
     
  9. tmilless macrumors newbie

    Joined:
    May 11, 2009
    #10
    I tried about all those methods and couldnt get any to work. Anyone know any generic smtp out server names? Im about ready to create a gmail and forward everything to that.
     
  10. tommggg Guest

    #11
    go to
    1 settings
    2 mail etc
    3 click your account
    4 smtp
    5 AT&T smtp server
    6 turn it on.

    however it will only send up to 3 mb....
     
  11. delpy8 macrumors newbie

    Joined:
    Apr 13, 2010
    #12
    netscape address wont send emails

    Hi forum,

    I can get mail but cannot send and email saying invalid address,

    Any help would be appreciated my details below I have a netscape address

    Host name smtp.aol.com
    User name is correct
    Password is correct
    Use SSL on, cannot turn off
    Authentication Password
    Server Port 587
     
  12. Droog83 macrumors newbie

    Joined:
    Apr 22, 2010
    #13
    I'm having this exact same problem! Can anyone help?

    One thing I noticed; when I looked in the outbox at the offending email that wouldn't send, I checked the address in the 'From' bar (i.e. the aol address registered my iPhone) and instead of saying <email address>@aim.com it says <email address>@aim.com@aol.com - so for some reason it's randomly added @aol.com to the end of my outgoing email address!

    I've checked and double checked that my email address is correct in my settings and contacts. I don't know why it's started doing this! ARGH!!
     
  13. Droog83 macrumors newbie

    Joined:
    Apr 22, 2010
    #14
    For anyone having the problem I had here ^^ I've managed to solve it!

    I went into settings > Mail, Contacts + Calendars and deleted my email account, then created it again only rather than tap the 'AOL' option I created one from 'Other' instead and entered my AOL email details there. The problem seemed to be a conflict between the .aim and .aol smtp servers.
     
  14. Parahandy macrumors newbie

    Joined:
    May 6, 2010
    #15
    Having the exact same problem but nothing is working, I am also unable to send from Mail on my Mac at home so affecting both.

    Strangely, could it be that AOL are having server problems as I have a USA based account which is not working but my UK based one (they have different screen names) is working?
     
  15. booch221 macrumors newbie

    Joined:
    Mar 5, 2010
    Location:
    Anchorage AK
    #16
    I read through all the post and eventually found this solution.

    1.Settings
    2.Mal, Contacts, Calendars
    3.Click on the pop account you are having issues with
    4.Click SMTP under "Outgoing Mail Server"
    5.IS the Primary Server your Pop acct? and is it on?
    6.Click on it
    7.I had to put in my user name and password where it said optional
    8.For me SSL is OFF
    9.Authentication is set to password
    10. Port 25



    I finally got it to work by adding a new server with the settings as shown above and turning off the primary server which I was unable to edit, because the fields were all grayed out.
     
  16. Peter Holt macrumors newbie

    Joined:
    Aug 18, 2010
    #17
    CAn receive burt not send in 3G

    I have downloaded latest software. It said "can't complete" but it seems to. However when in I Tunes it asks me if I want the latest update?? So, I have, what I think is V4 on by 3Gs. In/out emails works fine in Wifi, but in 3G I can only receive. I get the same message other have if I try to send. I have done everything suggested - no luck. I visited the Genius Bar at the Apple Store in Brighton, UK and they had no suggestions. My domain is hosted by Entanet.
    Any ideas out there.
    Thanks
    Peter
     

Share This Page