iPhone Case Program app not working

Discussion in 'iPhone' started by NikolasMason, Jul 27, 2010.

  1. NikolasMason macrumors member

    Joined:
    Oct 16, 2008
    #1
    I looked around but I couldn't find any one else posting about this problem. I installed the iPhone Case Program app on my iPhone and entered my iTunes password when it asked, but then it said "We're unable to process your request at this time. Please try again later", or something similar. I assumed it was simply because I had tried doing it right away that maybe their servers were being pounded, but I have kept trying for the last few days and it still doesn't work. I've seen a ton of other people who seem to have got their case orders through with no problem.

    Did anyone else experience this and know what the problem is? It's weird.
     
  2. Queen of Spades macrumors 68030

    Queen of Spades

    Joined:
    May 9, 2008
    Location:
    The Iron Throne
    #2
    Yes, the exact same thing happened to me. Apple was no help. The only way I could get it to work was to restore my phone, set it up as new, and then download the app. Once ordered, I just restored from my backup.

    Good luck. Don't forget to back up first.
     

Share This Page