iphone causes PS3 to disconnect from wifi

Discussion in 'iPhone' started by Bugg, Aug 5, 2010.

  1. Bugg macrumors newbie

    Joined:
    Jul 26, 2010
    #1
    Not sure if anybody has had this problem.

    Both my iphone and PS3 are able to connect to my wifi network just fine. However, anytime I connect my iphone to the wifi it causes my PS3 to lose its connection. The only way to fix it has been to turn off the wifi on the phone then reboot the modem. If it matters, my friend connected her nexus one to my wifi and it caused the same problem. Any ideas on how to fix this would be greatly appreciated.

    The modem is a motorala sbg900.

    Thanks
     
  2. IronLogik macrumors 6502

    Joined:
    Jun 15, 2009
    #2
    Is your router 802.11 N compatible? If so this might mean that your phones are accessing that band. But your PS3 is unable to access 802.11n, only 802.11g. Some routers only broadcast over 1 of those bands at once. So a G device may not be able to communicate until other devices are removed from the network that are preventing it from using 802.11g
     
  3. powaking macrumors 6502

    powaking

    Joined:
    Jul 3, 2008
    #3
    By any chance do you have your router set to only give out a certain number of DHCP ip addresses?
     
  4. nunes013 macrumors 65816

    nunes013

    Joined:
    May 24, 2010
    Location:
    Connecticut
    #4
    the only thing i can think of is since its a g router it cant handle as much as an N router and that the ps3 takes up so much bandwidth that when the iphone is on it there is not enough to run both especially if u have a slow internet connection, i know my internet connection is slow and its hard to run xbox live with a laptop and an iphone all at the same time. my response kind of sucks but thats all i could think of
     
  5. iluvifone macrumors 6502

    Joined:
    Jun 28, 2010
    #5
    I just finished playing some COD on my ps3, with my iphone in my lap. No issues whatsoever.
     
  6. IronLogik macrumors 6502

    Joined:
    Jun 15, 2009
    #6
    not possible. The PS3 is unlikely to use all of the bandwidth available to the frequency band as most cable modems and dsl connections aren't capable of providing the max bandwidth of the wifi connection. It's also highly unlikely that it would prevent devices from operating on the network if this were to happen anyway. They would just be slow.

    My answer is much more plausible. Basically devices exist in two different "variations" right now. 802.11g and 802.11n. There are still legacy devices operating on 802.11b, but meh...

    Apple's previous Airport Extreme was 802.11n (draft) compatible. But it could only operate on 802.11g or 802.11n, not both at the same time.

    So if one device is 802.11n, and another device is 802.11g it would fall back on 802.11g for all devices because it's operating at the highest common denominator (802.11g in this case).

    If you have a different router it may not fall back and instead just prevent other devices from hitting the router at all while 802.11n devices are present in the list. Many routers also allow you to say to NOT fall back if 802.11g devices try to operate on the network... meaning if an 802.11n device is on it, tough crap for the 802.11g device.

    Check your router out spec-wise online, check your settings. See if there is anything similar to what I'm saying here and you'll probably find your problem.

    It could also be a bug with the router... try updating the firmware on it.
     
  7. Bakakage macrumors 6502

    Joined:
    Jun 18, 2009
    #7
    Set up a static ip address on the ps3 or just get a new router.
     
  8. RonHC macrumors 6502a

    RonHC

    Joined:
    Apr 27, 2010
    #8
    You're connecting it wrong.

    - Sent from my White iPhone 4
     
  9. nunes013 macrumors 65816

    nunes013

    Joined:
    May 24, 2010
    Location:
    Connecticut
    #9
    i said my answers sucked, but i looked up the router, its only a "g" so thats why i didnt mention your answer
     
  10. IronLogik macrumors 6502

    Joined:
    Jun 15, 2009
    #10
    lol... get a new router... talk about extreme.
     
  11. Bugg thread starter macrumors newbie

    Joined:
    Jul 26, 2010
    #11
    I'm sure it's a problem with the router and I'm planning on switching from comcast to uverse pretty soon, so I don't really want to buy a new router....Something else strange though...If my PS3 is turned on and connected, I can connect the iphone without disturbing the connection. The problem only happens when I turn on the PS3 while the iphone is connected.
     
  12. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #12
    If the router is set to automatically select a wireless channel, disable that and manually select one, preferably based upon what you're neighbors aren't already using. Check to ensure that it has the latest firmware. Also try a different encryption setting; if you are currently using WPA/TKIP try switching to WPA2/TKIP. As a test you could also temporarily disable encryption to see if it solves the issue. Note that the U-verse 2WIRE gateway is pretty spotty in its own way with wifi so you might end up having to buy a new router anyway if all-else fails.
     

Share This Page