iPhone charging lag when connected?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Kidder1994, Apr 3, 2016.

  1. Kidder1994, Apr 3, 2016
    Last edited: Apr 3, 2016

    Kidder1994 macrumors regular

    Joined:
    May 20, 2012
    #1
    Hi everyone, i have a little doubt about my iphone 6s... when i put it on a dock or connect it to a lighting cable, the iphone sometimes doesnt change to "charging", and instead it stays with black screen, after some seconds it starts to charge... or the fastest solution is to unplug and plug it again and it will start to charge normally... it's like a delay between the iphone plug in and the software recognizing it's charging...

    This happens to someone else?
     
  2. Kidder1994 thread starter macrumors regular

    Joined:
    May 20, 2012
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    There is no need to bump posts.

    When you plug your phone in its not instant and never has since the lightning cable came about. There is a handshake that takes place when the cable is plugged in. It's normal.
     
  4. Kidder1994 thread starter macrumors regular

    Joined:
    May 20, 2012
    #4
    Sometimes people need some kind of a bump to give an answer here xD

    Today this happened again, i connected my iphone to my iphone lightning dock and the screen keep black for some seconds, i pressed the sleep/wake button and nothing happened... after like 15 seconds the screen turned on and it displayed something like this "this accessory is not suited and may not work reliably on iphone"... i unplugged it and plugged it again and started to charge whitout any message or issue... (it's the original iphone charging dock, the one that comes in 4 colours)

    Then i unplugged the lightning cable (original) from the dock and plug it to the iphone directly to the wall charger (original too)... and i had no problems whatsoever, yesterday i restored the iphone using the same lightning cable but now connected to my macbook and the iphone answered almost instantly...

    so idk what is happening here, i'm a little confused.
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    I wouldn't personally go with a faulty battery. I dirty port though. When was the last time you cleaned out the Lightning port??
     
  6. darthlinux macrumors member

    Joined:
    Jul 12, 2011
    #6
    I recently brought an Iphone 6s and I have the same issue when using a computer to charge my iphone, so I cam guessing the handshake thing is taking its time.
     
  7. davidg4781 macrumors 68000

    Joined:
    Oct 28, 2006
    Location:
    Alice, TX
    #7
    I think this happens when I plug it into my mini. If I'm just using a power cable connected to the wall it instantly vibrates and shows charging. I was concerned at first until I realized it was just doing it with the mini.
     

Share This Page