iPhone connects to network at startup then disconnects! Help Please

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Simon1822, Dec 16, 2012.

  1. Simon1822 macrumors newbie

    Joined:
    Dec 16, 2012
    #1
    My iPhone will randomly disconnect from the network, start searching, then say no service. I've tried airplane mode on and off, and doing a hard reboot multiple times. When I reboot it, it connects to the network, bars and 3G for about 5 seconds, then it disconnects and says no service. I pretty much can't use my phone. I am jailbroken and have messed around with the APN settings because I was getting "could not activate cellular data network" The APN settings work fine , until all of this happens.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Sounds like your iphone is having a hardware issue.
    The apn settings have nothing to do with it keep losing connection to the network.
     
  3. Simon1822 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #3
    Time to get an iPhone 5 maybe :D

    I'm currently trying to restore back to 5.1.1 and see if it helps
     
  4. Simon1822 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #4
    Anyone?

    I restored and it's the same problem, Are you sure it's hardware? I've had the phone for months and this randomly started now
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Not sure cause just like you I'm throwing suggestions. Can't know for sure if I don't have it open in front of me to check the hardware.
    You could try a different sim to rule that out.
    Don't what else to tell you. Bring it to apple or an iPhone repair place to have it checked out.
     
  6. Simon1822 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #6
    I did a complete restore and so far it is working fine without any problems, let's hope for the best. Thank you!
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Nice, hope it doesnt give you any more probs.
     
  8. Simon1822 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #8
  9. Simon1822 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #9
    To help out anyone else who has this problem in the future, the tweak "icaughtU"" was the problem of this, once uninstalled I haven't had any problems
     

Share This Page