Iphone Constantly getting"Call Failed" - Possible Solutions

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mludlow, Aug 31, 2010.

  1. mludlow macrumors newbie

    Joined:
    Aug 31, 2010
    #1
    If you are constantly getting "call failed" but you can still receive calls and use data this might help out.

    I started having this problem every morning when I turned off airplane mode to start my day. One of the following usually fixes this problem.

    1. Make sure the Date and Time aren't set "automatically", Manually select your home town, the phone is defaulted to Cupernico and if the phone and your service provider aren't time synced it could cause problems.

    2. Turn airplane mode off/on

    3. Reset Network Settings

    4. Turn on "Show My caller ID" This seems to be the one that works most constantly for me if the others don't work. Seems that when you start the phone or turn off airplane mode, this option doesn't load up correctly.


    Hope these are helpful.
     
  2. keerti macrumors newbie

    Joined:
    Nov 7, 2010
    #2
    I am sooooooooooooo angry right now !!

    This iphone 3g 's got me so ****in pissed , i 'd throw it under a truck!
    it used to throw up that 'call failed' msg once in awhile before.
    and a toggle wit the call waiting setting wud help , but now it does that twice everyday!
    sometimes it gets OK after i toggle with the call settings , but otherwise , nost of the times it simply doesnt.!
    and i have to borrow a frend's phone to make a call !!
    and i paid ****in 300quid for this piece of **** phone !

    btw its an iPhone 3g , black , 8gig piece of **** runnin ios 4.0
    someone please help me before i hang myself :(
     
  3. hasnainpatel macrumors newbie

    Joined:
    Nov 21, 2010
    #3
    Thanks. It works for me as well. Point is why does it happen
     
  4. ssdeg7 macrumors 6502a

    ssdeg7

    Joined:
    Jul 15, 2010
    #4
    I have an iPhone 4 and this happens about every two days, i've tried doing all those, even turning off wifi and doing many more thinks and the problem seems to come back after a few days, and it always happens when you most need it.
     

Share This Page