iPhone constantly thinks headphones are plugged in!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ClemTiger0408, Apr 23, 2008.

  1. ClemTiger0408 macrumors 6502

    Jun 30, 2007

    My iPhone thinks I have headphones plugged in even when I do not. I cannot make calls without headphones now.

    Obviously I tried restarting the phone, plugging and removing headphones.

    Has anyone heard of this problem before? What should I do?
  2. OCP macrumors newbie

    Nov 26, 2007
    This happened to me today actually and all I did was plug the headphones that I used earlier back in and out again, and the phone is back to normal.
  3. NeoMayhem macrumors 6502a

    Aug 22, 2003
    Just plug and unplug the headphones about 10 times really quick. That fixes this problem most of the time. If not, clean out the port with a que tip and rubbing alcohol and then try it again.
  4. bencomley macrumors newbie

    Jun 19, 2009
    Clean the socket

    I've tried all the others with temporary sucess but the one that works is cleaning the socket with a cotton bud or Q tip dipped in pure alcohol. I've read a few things saying this is a bad idea but it works! And alcohol evaporates so quickly it doesn't have a chance to damage anything, just surface clean the socket contacts. Whatever else you read save yourself time and clean your headphone socket. It works!
    And if your not sure about which alcohol, I have used the hand steralising type that is common everywhere, for hand cleaning, with the swine flu pandemic.
  5. orpheus1120 macrumors 65816


    Jan 23, 2008
    Basically any type of clinical alcohol works. You may wanna try methylated spirit, acetone etc. You can get it from any local pharmacy/chemists depending which country you from.
  6. zulkiflim macrumors regular


    Jan 6, 2008

    i would recommend if you are using the solution above,make sure your phone is off.
    And you do it with the phone held vertical.
    Dont use too much alchohol....LOLOL..

    Either that just go back to the apple/at-t store for an exchange.

    It may either be a defective port / software.
  7. EVanr macrumors newbie

    Apr 10, 2013
    What should I do if none of these ideas work?

Share This Page