iPhone Contacting the iPhone software update server... (5.1 related)

Discussion in 'iOS 5 and earlier' started by Elven, Mar 7, 2012.

  1. Elven macrumors 6502a


    May 13, 2008
    Hello all.

    Well I am having no end of troubles even getting the download to begin with 5.1

    I am running Lion, on a 27inch iMac i7, I have updated with all the latest software including todays releases. From here I attempted to update my iPhone 4s 16GB White and am seeing the message in iTunes. (connected via usb)

    "Contacting the iPhone software update server"

    So far I have

    -Disabled Little Snitch

    -Repaired permissions

    -Dropped Wifi and switched to ethernet

    -Rebooted Twice

    -Cache cleaned ( CCleaner )

    I am at a loss as to the cause of this issue, my iPhone is NOT jailbroken nor has ever been.

    I sincerely hope someone can help me sort this.

  2. Tyler23 macrumors 603


    Dec 2, 2010
    Atlanta, GA
    Had the same issue earlier. MBP running 10.7.3 trying to update my 4s to 5.1.

    The issue lasted for about an hour of trying for me. It seems like it is lasting longer for you, but hopefully not too much longer.

    It seems as it's just an overloaded server. I turned off my firewall, updated iTunes and rebooted my computer several times, but to no avail. It just took time and patience.

    Good luck, hopefully you can update soon!
  3. Elven thread starter macrumors 6502a


    May 13, 2008
    Hey! thanks for the info. I'll try again later I am UK based so I guess all the people in the US are updating atm.

  4. Elven thread starter macrumors 6502a


    May 13, 2008
    Just wanting to follow this up, it's now 4am and while finishing some paperwork I attempted to update my iPhone 4S white 16GB once more and again facing the same issue.

    Anyone else with this problem in the UK :confused:
  5. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    Have you tried doing it directly from the iPhone. Worked great for me here in Toronto, Canada.
  6. Elven, Mar 7, 2012
    Last edited: Mar 7, 2012

    Elven thread starter macrumors 6502a


    May 13, 2008
    Yes, however when I go into update I get

    "an error occurred while checking for a software update"

    Iphone 4s White 16gb on Wifi.
  7. Cell-666 macrumors 6502a

    May 3, 2011
    I'm having the same issue and in the UK. Three iPads, two iPhone 4, 3 ATV's and one iPod. All doing the same.

    I'm downloading the full files from the front page as I can't be arsed waiting any longer :D
  8. Elven thread starter macrumors 6502a


    May 13, 2008
    Full files? I must have missed something could you please post/pm the url?
  9. Cell-666 macrumors 6502a

    May 3, 2011
  10. valdistt macrumors newbie

    Mar 8, 2012

    I had the same issue and I just solved it. Well - not exactly solved, but still found the reason. The problem is really somehow connected to your IP address. My iPhone 3GS also could not get update, so what I did - I disabled Wifi and checked for updates again. Then finally update appeared, still - as you know - you have to be on Wifi network to install updates. I turned on Wifi back - and again update is not accessible.
    As I am iOS developer, I also tried to download the update from developer.apple.com - still also there download is even not starting, therefore I assume, that problem is somehow connected with ours internet service providers and web address routing tables.
    I hope Apple will solve it, still if you need a sooner update, then simply find some other ISP with other IP address.
  11. jakesteramma macrumors member

    Oct 10, 2007
    It's definitely a DNS issue.

    This is what I did to work around it....

    My DNS setting is which is my DSL modem. I changed it to Google's DNS server at

    When I did this, the message "Contacting the iPad...." immediately went away and it started to download.

    Hope this helps!!! :)
  12. dthevis macrumors newbie

    Aug 12, 2011
    It is a DNS issue
    changing your DNS server or adding the following to your host file will resolve the issue appldnld.apple.com
  13. camyersx macrumors newbie

    Mar 8, 2012
    DNS workaround worked

    Thanks, Jakesteramma I had gotten very frustrated but your suggestion allowed me to download and install iOS 5.1!
  14. MesMaker macrumors newbie

    Nov 16, 2009
    Finally this worked.
    Added appldnld.apple.com to host file and updated per iTunes on my iMac.
  15. MesMaker macrumors newbie

    Nov 16, 2009
    This also worked for an OTA update on my iPad2. Changed the DNS to
  16. pedders macrumors newbie

    Mar 8, 2012
    hi guys I have tried all of the above but still no joy, the crazy thing is that when I went to Starbucks today around the corner from home I could download the update on the free wifi not enough data for all of it though :(
    I am in Auckland New Zealand
  17. aygie macrumors regular

    Oct 27, 2007
    Same here on my iPhone, iPad and Apple TV. This seems to be the fix.

    So bizarre, my network will not get any iOS updates (everything else is fine, iTunes App store etc) from any source including direct download links. Jump onto the next door neighbours wifi and its fine.

  18. Ashka macrumors 6502a


    Aug 9, 2008
    New Zealand
    I expect the servers are getting hammered..
    I'm near Levin.. no joy here either.
    Try again tomorrow.
  19. daveb99 macrumors member

    Jan 27, 2011
    I have the same problem on my Mac so will update my hosts file.

    If any of you have Windows installed under Bootcamp - try it that way (using direct download links to the IPSW files). Works perfectly :eek:
  20. bige12 macrumors 6502


    Apr 6, 2009
    Vienna, VA
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Same here my iPhone knows there is update, but my iPad 2 can not connect to the update server. I also get a error message say it has failed
  21. rjwhite macrumors newbie

    Feb 3, 2010
    Can anyone document a step by step process of how to do this? Please :)
  22. sou1 so1di3r macrumors 6502a

    sou1 so1di3r

    Jun 26, 2008
    Denver, CO
    I've been trying to update since yesterday OTA and on my Mac Mini..... both are just getting errors with no luck...... any ideas?? :confused:

    I'm in the Quad Cities, IL, USA
  23. foxtail1 macrumors newbie

    Mar 9, 2012
    Please! I've tried to follow the directions, but no joy. I can't get past the "contacting the iPhone/iPad software update server" and I've been trying for 2 days.

  24. foxtail1 macrumors newbie

    Mar 9, 2012
    Nevermind! I hadn't closed my Preferences window, so the changes had not been applied. Applied them (DNS to, and am downloading with no problem.
  25. rjwhite macrumors newbie

    Feb 3, 2010
    Ok for the benefit of anyone googling for it this is the step by step process i've just used for OS X Lion

    1. Open system preferences,
    2. Click on Network
    3. Highlight WIFI (should be at the top of the list) and click ADVANCED on the bottom right)
    4. Go to the DNS tab and make a note of your current DNS Server in case you want to change it back
    5. Click the + button and type
    6. Click OK
    7. Click Apply
    8. Try and download the software again.

Share This Page