iPhone contacts, Google sync & iCloud issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by krsn89, Nov 9, 2014.

  1. krsn89 macrumors newbie

    Joined:
    Nov 9, 2014
    #1
    Hi everyone,

    I'm having some issues getting my contacts synced correctly. I have searched a few forums looking for an answer for this particular problem and haven't found a solution yet so my apologies if I'm just missing something here.

    I have always synced my contacts via my Gmail account. In my Settings > Mail, Contacts, Calendars section, I have iCloud set up and then Gmail set up through Exchange for Contacts ONLY. If I added a contact on my iPhone, it would always sync directly to my Gmail Contact Manager. I only noticed this issue because I was given an iPad mini as a gift recently and noticed that not all of my contacts synced. I checked my Gmail Contact Manager this seems to be because any of the contacts I have added since probably last December are NOT listed. If I log into iCloud and check my contacts there, the only contact listed is me.

    If I go into my Contacts and hit Groups at the top left, all I see is Gmail/Exchange, Contacts (checked), Gmail/Exchange Global Address List (unchecked - if I try to click this no contacts appear at all), iCloud, All iCloud (checked). If I go into Settings > Mail, Contacts, Calendars and scroll down to the Contacts section, the Default Account is listed as Gmail/Exchange. I have tried clicking "Import SIM Contacts" to no avail, changing the Default Account and clicking and unclicking Groups.

    Where are the contacts I have added since December(ish) being stored? If they're not in my Google contacts nor in iCloud? How can I make them sync to my Google account again? Is there a way to "push"(?) everything to Google that I'm missing?

    Thank you all in advance!
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Your new iPad won't sync to Google using "Exchange". Search around for the reason.

    Add the account as a Google account.
     
  3. krsn89 thread starter macrumors newbie

    Joined:
    Nov 9, 2014
    #3
    Thanks for the reply. I'm not so concerned about syncing my contacts to my iPad as much as I am concerned about the fact that the sync that used to work between my iPhone and Google contacts is no longer working. I only mentioned the iPad thing as that is how I noticed the missing contacts in the first place. I need to know where my recent (btw Dec and now) contacts are being stored since they neither exist on my Google account nor iCloud.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    On which device were the contacts entered and what is the default account for that device?
     
  5. krsn89 thread starter macrumors newbie

    Joined:
    Nov 9, 2014
    #5
    They were entered on my iPhone and default contacts account is set to my Gmail/Exchange account.
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    You want to get them to Google and who knows what they're in...just "on the iPhone" I guess.

    There may be an app that will let you export (or email) multiple contacts. Otherwise you'd have to send them one at a time as CSV files.

    Once you know you have the new ones safe somewhere you can start over with the contact accounts on the iPhone...turn them off and then delete anything that's left.
     
  7. Arynaria macrumors newbie

    Joined:
    Nov 16, 2014
    #7
    This is primarily a workaround for calendar sync issues, but it could help with contacts too.
    1. Set up your account through Google (not Exchange) and make sure "Contacts" is turned on.
    2. Go to the "Mail, Contacts, Calendars" part of settings, and you'll see an option for "Fetch New Data" under your accounts.
    3. Open "Fetch New Data". At the bottom of the screen there is an option called "FETCH", which gives a little blurb about the schedule and battery life. It will likely be set to "Manually".
    4. Change the setting from "Manually" to "Hourly".
    5. If it works similarly to the calendars, your contacts should now sync like they did before with Exchange.
    This was tested on an iPhone 6 with iOS 8.1, but it will probably work for earlier iOS versions, since the settings menus haven't changed too much.

    Regarding your missing contacts, I don't know where anything is "stored" - but for future reference you may want to consider setting up an IFTTT recipe that auto-adds a line/entry to a Google Spreadsheet whenever you add a new contact to your phone.

    Hope this helps. :)
     
  8. B737 macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #8
    if you dont want to set up your contacts to fetch through the built in google ..

    go to ADD account under email, and you add under "contacts" a "CARDDAV" account. server is google.com username is you@gmail.com and your password. this is the closest you will get to the old 'exchange' system. it will manage your contacts.
     

Share This Page