Iphone could not be restored. Unknown Error occurred (6)

Discussion in 'Jailbreaks and iOS Hacks' started by DaMuffinMan1992, Aug 9, 2008.

  1. DaMuffinMan1992 macrumors newbie

    Aug 2, 2008

    Just tried jailbreaking my iphone to 2.0.1 but when i follow all the instructions i get to "The iphone could not be restored. Unknown Error Occurred (6)"

    Any idea how to fix this so it works?

    Thank you very much =)
  2. DaMuffinMan1992 thread starter macrumors newbie

    Aug 2, 2008
    Anyone got any idea's?

    I have tried restarting PC, re downloading the firmware file and i am running out of idea's :S
  3. shinbo macrumors newbie

    Aug 9, 2008
    I also got the same error when trying to install the new winpwned firmware... Anybody got ideas?
  4. outz macrumors 6502

    Jul 17, 2007
    normally when I receive this error it is when I am attempting to restore the pwned image via itunes when i am not in the 'true dfu' mode.

    "To do this, hold down the ‘power’ and ‘home’ buttons at the same time for ten seconds (turning your iPhone off), and then immediately release the ‘power’ button and continue to hold the ‘home’ button for another ten seconds. Your iTunes should recognize your device and your iPhone screen should be ALL BLACK. If you see the docking screen, you have hit the actual ‘Recovery Mode’ and need to repeat the process until you get the blank ALL BLACK iPhone screen"
  5. 8CoreWhore macrumors 68020


    Jan 17, 2008
    Big D
    Start from the beginning and do the whole thing again with the custom .ipsw. If that doesn't work, try it from the beginning, use the virgin .ipsw. Good luck. Don't worry, your phone is not dead, you just need to keep at it, read the forums, it'll work out. :)
  6. DaMuffinMan1992 thread starter macrumors newbie

    Aug 2, 2008
    Tried again and made sure the entire screen was black when it was in DFU mode. Same Error.

    It is normal for the apple logo to come up on screen right? Like when it is meant to be "recovering" .

    I have tried everything, this is rather annoying =P
  7. a1rjumpman23 macrumors member

    Jul 15, 2008
    I got the same error too. I'm on a unlocked/jailbroken 1st gem iPhone but when I try to restore I get an error that my iPhone can't load or something. I'm using iTunes 7.7.1 so I don't know what's wrong
  8. geeb macrumors regular

    Jul 1, 2008
    Error 6 means your itunes/phone isnt pwned correctly

    Rerun winpwn or xpwn and repwn the phone correctly.

    irc.osx86.hu #xpwn for assistance
  9. jeffmc macrumors 6502

    Sep 21, 2007
    you iphone is rejecting the image, which means it's either:

    a) not been pwned correctly


    b) not correctly in DFU, it is NOT normal for an apple to be on screen while in DFU, it should be 100% blank and the phone should appear to be off but be recognized by the computer
  10. Steveo652 macrumors newbie

    Aug 12, 2008
    A solution to the restore problem

    I've been having the same problem. I tried to update my iPhone G3 to operating system 2.01, it failed, and told me I had to do a restore. All attempts at the restore failed, even after trying many, many hints on-line. I have a PC with an XP operating system. It is about 5+ years old. My solution was, finally, to go to my wife's newer system (less than a year old, with a Vista operating system), load iTunes latest version, and then plug in my iPhone. At first it didn't recognize the iPhone, but then after doing the "hold down the power and that other key" trick, it finally recoginized it and again told me that I needed to do a restore. I did the restore, and viola, it worked!!! One thing, it did a restore to V2.01, the latest operating system, something my older computer never tried. After the successful restore I took the iPhone back to my older computer (it still had all my backup stuff from my old iPhone), and did a synch with my old data. It asked me if I wanted to erase the information from the new computer, and I said "Yes", and it then resysnched all of my old data. Apparently my old computer had the wrong USB (older system) or didn't have the more up-to-date driver needed to accept the iPhone. Anyway, it works now!! Now if I could only get it to send email using charter.net...
    Good luck to all, Steveo
  11. christos2b macrumors newbie

    Aug 23, 2008
    I am a very new owner of a regular iphone 3g (not jailbreaked, not pawned). After 3-4 hours of operations and during an effort to retieve my e-mails from my Yahoo accounts my iphone become dead. Any efforts to awake it were worthless. I tried to restore using your guides but after trying to restore through itunes i received several times the following message (Iphone couldn;t be restored. Uknown error (6) and the screen become white. The Iphone is surely in the DMU (something like that mode) because it is off but my pc can recognise it. I tried to restore it in 2 different pcs which running Vista Ultimate but nothing. Any ideas before I smash it or return it to the store (Damn it is still Saturday and the stores will be closed for another 36 hours)!

  12. TheBold macrumors member

    Aug 21, 2008
    Make sure that you restore it while it is in DFU mode, read more about DFU mode HERE

    when I used the WinPwn 2.0.4 I had the same error, tried to restore to the original firmware but failed, then did it once again using the custom firmware and it went FINE.

    good luck
  13. christos2b macrumors newbie

    Aug 23, 2008
    Thanx for your reply. It is surely in DFU mode. Being desperate i downloaded Winpwn, I created a custom restore file but the same. I have made over 20 efforts to restore the damn phonme but at the end I receive an "Uknown Error 6" on Itunes and a white screen on my phone.
  14. DN7335 macrumors 6502

    Jun 9, 2008
    I was getting an error also, not sure if it was Error 6 or not but I think it was. Turned out I had a bad 2.0.2 firmware file. I had iTunes download the file again and even though it was identical to my first file (name, file size, etc), when I did the restore using the new file it worked. Hope this helps, good luck.
  15. christos2b macrumors newbie

    Aug 23, 2008
    I have downloaded version 2.0.2 3-4 times. I even tried to install the version 2.0.1 or a pawned 2.0.1. version but nothing. Still the same. Tomorrow I'm going to the Vodafone store where I purchased to see what they can do.
  16. DN7335 macrumors 6502

    Jun 9, 2008
    Sounds like you might have a faulty phone, hopefully the store will replace it for you.

Share This Page