iPhone Crashes iTunes after using Touch Copy

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TheConfuzed1, Oct 14, 2010.

  1. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #1
    I had a problem that I posted here.

    In that thread, with the help of another poster, I was able to identify my problem.

    The suggestion was that I use Touch Copy to delete some problem image files.

    Touch Copy continued to freeze on my old Powerbook though, so I started searching for an alternative.

    That is how I discovered iPhone Explorer, which I love, by the way!

    iPhone Explorer fixed that problem, but I have a new issue that I suspect has arisen somehow from Touch Copy.

    My iPhone now crashes iTunes!

    It doesn't matter if iTunes is running before plugging it in, or after. As soon as it tries to mount my iPhone, it crashes!

    It's weird, because the iPhone is otherwise working normally (now), and iPhone Explorer is able to read it.

    I even tried to mount my iPhone using iTunes on another user account, so I do believe the problem is with the phone itself.

    Is there a known file that causes this, that can be safely deleted?

    I thank you in advance for your answer!
     
  2. TheConfuzed1 thread starter macrumors 6502a

    Joined:
    Jun 4, 2003
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    35 views and nothing yet?

    This isn't looking good. 
     
  3. LSP414 macrumors newbie

    Joined:
    Nov 12, 2010
    #3
    Possible Solution

    I just spent an hour on phone with Apple Support. After many failed options I tried installing and then connecting to iTunes on a PC ( i am on a Mac) to see if it would crash iTunes on the PC. It actually mounted and would have allowed me to sync, upgrade etc. At the support persons suggestion we tried to connect again to the Mac. It mounted and didn't crash iTunes. I was able to sync and it now works as it did before. I also have a 3G with the same problem and it fixed that too.

    Hope it works for you.:
     
  4. TheConfuzed1 thread starter macrumors 6502a

    Joined:
    Jun 4, 2003
    #4
    Thank you SO much for posting this!!!

    I am at work, and I tried mounting my iPhone on a coworkers Windows laptop just to try this.

    It worked! I haven't tried connecting it to my Mac yet, but while it was connected I went ahead and jailbroke it again, and installed SSH, so at the very least, I can now create manual backups of the files I need! 

    You are my personal hero. I am just glad that after all this time I still haven't restored and lost all of that data!
     

Share This Page