Iphone Data Keeps Getting Erased!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dhymowit, Jan 2, 2011.

  1. dhymowit macrumors newbie

    Joined:
    Jan 2, 2011
    #1
    Hoping someone might be able to help me with this. The other day my Iphone 3G (at the time jailbroken and unlocked) just suddenly lost all of its data. I have now restored the phone two times but the phone keeps subsequently losing all of its data again. Does anyone know why this would be? The most recent time I lost the data it was right as I disconnected the phone from Itunes. But this did not seem to be the case in the other two instances. I've been searching around this forum and others but don't seem to see any posts about this phenomenon.

    Prior to the other day, the phone was working just fine.

    Thanks for any guidance on this. Glad to clarify any questions.
     
  2. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
  3. dhymowit, Jan 3, 2011
    Last edited: Jan 3, 2011

    dhymowit thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #3
    I am restoring as new.

    OK... So I have an update because I realize I was wrong about what was happening. The phone is not in fact repeatedly getting erased. It now seems to be stuck in the following pattern. I restored the phone as new to OS 4.1 after the phone did in fact get erased the first time. The phone is no longer jailbroken or unlocked at this point. I am able to put my old applications back on the phone. However, it seems like after a certain amount of time my screen keeps going back to the mode where it asks me to plug my phone back into Itunes. Even though my phone is still plugged in and connected to Itunes. At this point Itunes gives me the message that Itunes has detected a phone in recovery mode (making me think all of my data was again lost).

    But the weird thing from here is that if I unplug the phone and turn it off and then turn it back on after a while, I am able to get it to boot back up correctly to its locked OS 4.1 state. I incorrectly assumed when the phone got to the screen asking me to plug it back into Itunes that the phone had lost all if its data.

    So now the question becomes how do I get the Iphone to stop doing this? Any advice???

    Thanks...
     
  4. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #4
    That could be a hardware issue. It could be your dock area is teeming with dust and other particles. Try using compressed air to clear that area out.
    If that doesn't do the trick, you might have to take it in.
     

Share This Page