iPhone data with o2 pay&go please help :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wattso, Mar 16, 2008.

  1. wattso macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #1
    Hi all.

    Just got an unlocked 1.1.3 iphone today. Very pleased. However, I cannot get on safari with it. I have been researching this for hours and am no closer to the answer. Please help.

    Here's the problem. Basically I cant get on the internet, i'm with o2 pay&go. When I first got it safari would say something to the effect of "safari can't open the page because it can't find the server" and then it would say "could not activate EDGE: You are not subscribed to EDGE" I do not have the edge page under settings>general>network. I then discovered that I can access this when I put a different networks sim card in the iphone. So I swapped the sim cards and reswapped them while on that edge menu and then put various settings into that page. Non of them have solved the problem. Although one brought a different message up, something like "the connection to the server has been lost" but that particular setting did work with one web page only, o2's iphone page.

    Please please please can somebody help me. I have looked around I would appreciate actual instructions instead of a link.

    I understand that I wont achieve edge with my pay&go sim but I thought gprs would work. Am I wrong? Please help

    Thanks In Advance
     
  2. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #2
    follow this:
    1) Activate open SSH and connect to your iPhone
    2) Go to /<root>/system/library/Carrier Bundles/O2_UK.bundle/
    3) Upload and replace the modified file 'carrier.plist' to the directory.
    4) Restart your iPhone.

    the carrier.plist is in the zip file attatched
     

    Attached Files:

  3. wattso thread starter macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #3
    thanks for the reply.

    I'm really sorry but I need more detail than that, I'm not very good with this kind of stuff. Sorry

    Also the zip file you attached opens with omnioutliner ? Is this right?
    Thanks again
     
  4. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #4
    ok, open installer on the iphone
    open all packages, and install community sources
    once thats done, install bsd subsystem, close and re open installer
    install openSSH on iphone

    then you need an SSH app on your computer. use transmit for mac, not sure about pc
    use google, search "ssh iphone windows"/"ssh iphone mac" for more help
    then follow the instructions :)
     
  5. wattso thread starter macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #5
    ok. So I've changed the protocol to sftp, put the server as the iphones ip address, user name as root and password as dottie in transmit. Clicked connect and get a message "could not connect to server".

    What am I doing wrong?

    Thanks for all the help so far.
     
  6. wattso thread starter macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #6
    Thankyou very much sir. I've managed to connect and upload the modified file using the password alpine.

    Now, one small problem, safari still isn't working. But I do now have the edge setting. Now what do I do? :D

    Thankyou again
     
  7. wattso thread starter macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #7
    Scrub that. Got it working with the help from another topic on this forum.

    Thanks again.

    (god it's slow :D ;) )
     

Share This Page