iPhone destroys SIM card

Discussion in 'Jailbreaks and iOS Hacks' started by Manuva, Mar 26, 2011.

  1. Manuva macrumors newbie

    Joined:
    Mar 26, 2011
    #1
    Hi
    I am experiencing probably one of the most annoying errors with my iPhone 3GS. I am running firmware 4.2.1 and had no problems jailbreaking and unlocking it. Everything worked out fine, however, after about 2 weeks my phone suddenly showed the "No SIM" notification. I took out the SIM card and put it back again but nothing happened not even the notification showed up anymore. When I put my SIM card to another phone it would not work either. So I talked to my carrier who gave me a new card and it worked perfectly. At least that's what I thought. Because after two weeks the same thing happened to me (the "No SIM" notification suddenly showed up again). I changed my SIM card three times in the two months and simply cannot figure out what keeps destroying them. Any suggestions?
     
  2. mojohanna macrumors 6502a

    mojohanna

    Joined:
    Jul 7, 2004
    Location:
    Cleveland
    #2
    Restore your phone with out the jailbreak and see if it happens again. If so, replace the phone. If not lose the jailbreak.
     
  3. Manuva, Mar 26, 2011
    Last edited: Mar 26, 2011

    Manuva thread starter macrumors newbie

    Joined:
    Mar 26, 2011
    #3
    It's not that easy. I need the jailbreak because of the unlock (it's not factory unlocked). And the SIM card doesn't work with any phone although the iPhone recognizes all cards but mine.
    EDIT: I went to the Hutchinson Three shop and they once again gave me a new SIM so my iPhone is working again. Hopefully the new jailbreak will help. The guy in the shop told me that they get a lot of complains by iPhone 3G users who have the same problem as I do. Most probably the reason for the destruction of the SIM card is that there is a minimal electrical charge that just ruins the USIMs.
     

Share This Page