iPhone Dev Team Jailbreak 2.2.1 Official Release

Discussion in 'Jailbreaks and iOS Hacks' started by murc585, Jan 30, 2009.

  1. murc585 macrumors regular

    Joined:
    Jan 29, 2008
    #1
    The iPhone Dev Team have updated their site saying they have a new version of Pwnage Tool and quickpwn. They have added instructions for us suckers with 10.5.6 to allow DFU mode to work again. Check it out for yourselves!

    http://blog.iphone-dev.org/

    EDIT: go to their "official torrents" section on the sidebar and it will show you the bittorrent links.
     
  2. OrangeDog macrumors 6502

    Joined:
    Oct 20, 2008
  3. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
  4. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #4
    I am a bit out of it JB-wise; so does 10.5.6 present a problem? Do I have to get the developer account to downgrade to 10.5.5?
     
  5. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
  6. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
  7. avediswolf macrumors regular

    avediswolf

    Joined:
    Jul 23, 2008
    Location:
    Ohio
    #7
    you would just be downgrading the IOUSB "Driver"

    I also heard using a USB hub between the Mac and the iPhone works as well, though I haven't personally tried it.
     
  8. StevnJ9971 macrumors member

    Joined:
    Aug 31, 2008
    #8
    I can confirm the USB hub fix. I used that when I jailbroke my iPhone to 2.2 and it worked perfectly fine.
     
  9. istinkles macrumors member

    Joined:
    Sep 22, 2008
    #9
    ahh the dev-team. They never fail to release patch. It's kinda funny how they are always so quick to do it. and I haven't tried with 2.2.1 yet, but I always hook my iPhone up through a hub, and never had any problems. so that should work.:apple:
     
  10. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #10
    OK, so I can JB on 5.6 if I use a hub?
     
  11. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #11
    from the many posts i have read on these forums yes using a hub should bypass the 10.5.6 DFU restore problem
     
  12. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #12
    thanks for the assurance, I will try this when I get home. I haven't been JB'ed since 2.1.
     
  13. WPB2 macrumors 6502a

    WPB2

    Joined:
    Jul 1, 2008
    Location:
    Southeast, LA
    #13
    Ah, another JB. I am getting pretty good at it, as I have JB'ed every firmware from 2.0. Gotta wait till I get home though.
     
  14. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #14
    Has anyone tried the un-official WinPwn? I think I'll just wait for the official one... :D
     
  15. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
  16. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #16
    can anyone help me?
    I try to make a custom 2.2.1 firmware using pwnagetool .. I install AptBackup and Bossprefs as defaults packages. I'd like to add yellowsn0w as well; but when I add the apt9.yello..... source, I can't "refresh" the list and get yellowsn0w to appear.

    Am I doing something wrong?
     
  17. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #17
    Ok it's not only yellowsn0w source.
    I also tried to add apt.hebdev.com but when I select it from the source list and hit "refresh" nothing happens :(
     
  18. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #18
    I had a similar problem. Try re-installing Cydia via itself. ;)
     
  19. jw12345678 macrumors member

    jw12345678

    Joined:
    Jan 28, 2009
    Location:
    UK
    #19
    oops!

    I tried installing the IOUSBFamily-315.4.1.pkg but then got the grey rolling screen telling me to restart by holding the restart button... and wouldn't start at all. (had to connect to another mac and reinstall the 10.5.6 version to get the machine working again!) Any ideas what i did wrong?
     
  20. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #20
    no, but this is happening at the Pwnage tool level.. i haven't made the custom ipsw yet
     
  21. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #21
    Huh? You're trying to add a source when you're not even Jailbroken? If this is a feature of PwnageTool then do excuse me, I'm limited to Windows/Linux, so no PwnageTool for me. :(
     
  22. notintheleast macrumors 6502

    notintheleast

    Joined:
    Oct 1, 2008
    Location:
    NC
    #22
    Yeah, with Pwnage tool you can add packages to cydia on your desktop while building the custom .ispw. Purdy nifty.
     
  23. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
  24. notintheleast macrumors 6502

    notintheleast

    Joined:
    Oct 1, 2008
    Location:
    NC
    #24
    Indeed my friend. And I need a new one.....

    BTW Tokio, I'd like to commend you on keeping everyone straight about all of this back up stuff today. You've really been on top of it, and even reassured me about a few things, so thanks. :D
     
  25. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #25

    yep but there's something wrong when adding extra sources.. the 4 the tool comes with are fine.. but I can't seem to add custom sources and download packages from them :/
     

Share This Page