iPhone display problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by 9rithesh, Oct 29, 2008.

  1. 9rithesh macrumors newbie

    Joined:
    Sep 9, 2008
    #1
    Hi, I have this problem on my iPhone. When a call is done instead of the display go blank my display glows in a dim mode. Like it just shows the dim wallpaper with no signal and battery indication. This occurs often, even when no call is done. The dim lite appears as if some text message or email is received and nothing of such sort is occurs. I restored my iphone and installed a fresh batch of iTunes but no help.

    Can anyone suggest me a solution for this problem?
     
  2. Mini-Mac macrumors newbie

    Joined:
    Oct 3, 2008
    #2
    Re: Did you try an Erase All Content and Settings?

    I'm assuming you have an iPhone 3G? In Settings -> General -> Reset there are six choices. The second one down is "Erase All Content and Settings". Did you try this? It may not be a bad idea. I had a display dimming problem that basically was intermittent. Even resetting the iPhone did not make a difference until I tried this. With your problem though, this may not work, as I'm not sure if you are experiencing a hardware issue or Firmware problem. If you do try this reset procedure, it will take about two (2) hours and it's important that you Sync your iPhone 3G with iTunes immediately BEFORE trying this, as you will want to restore all your info. after the reset.

    Good luck 9rithesh. Let us know if this helped with your display problem.
     
  3. 9rithesh thread starter macrumors newbie

    Joined:
    Sep 9, 2008
    #3
    Thanks for your advice Mini-Mac I will do that. Well AFAIK it's a s/w prob, coz I experienced the same prob earlier in my previous iPhone. Apple swapped me a phone and I experience the same prob again.

    Let me do as u say and will revert back.
     
  4. 9rithesh thread starter macrumors newbie

    Joined:
    Sep 9, 2008
    #4
    I still have this problem on my iphone for you guys reference am attaching a picture so it makes a good understanding of the problem.

    [​IMG]

    Here the problem is the time is missing and "slide to unlock" is missing any help is appreciated tried all types of restores and formatting.
     

Share This Page