iPhone does not see the last received email from gmail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ElBerserko, Jan 26, 2008.

  1. ElBerserko macrumors member

    Joined:
    Jun 30, 2007
    #1
    Since yesterday I have been having an issue where iPhone will not receive the last email from gmail imap. For example, if I send myself a test email to my gmail account, the iPhone Mail app will not see it even after manual checks. If I send myself a second email, suddenly the first test email will show up but the second will not. This has rendered the mail app nearly useless, as I can never see the last email I received.

    I have 1.1.3 and setup using the manual IMAP settings, although I have tried it with the Gmail automatic setup as well with no difference. I have another IMAP account not with gmail that appears to work fine. I have also tested my gmail IMAP on my computer with Mail.app with no problems.

    I have already tried rebooting and restoring but that didn't help. Any ideas?
     
  2. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #2
    I have the same problem, see my post here. Sorry that I didn't see your thread before starting my own.

    Is your account working normal again? I have the problem with one Gmail account, the other 3 work fine.
     
  3. ElBerserko thread starter macrumors member

    Joined:
    Jun 30, 2007
    #3
    Yeah I still have the same problem. Seems kind of strange that it started around the same time for both of us.
     
  4. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #4
    Very annoying. I've posted on several forums (incl. Gmail help Google group) but didn't get anything so far. The weird thing is that the other Gmail accounts on my iPhone don't exhibit the problem.
     
  5. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #5
    Just an update. I read an article on lifehacker.com about the new version of the Firefox Better Gmail add-on. The article states that Google has "rolled out some code changes to Gmail" in the past week.

    I wonder if our IMAP problems are related...
     
  6. Prodger macrumors newbie

    Joined:
    Jan 28, 2008
    #6
    The same thing is happening to me. It started about two days ago when I noticed that my email wasn't being pulled from gmail to my iphone...
    how odd...
     
  7. linsam macrumors 6502

    linsam

    Joined:
    Jul 3, 2007
    Location:
    Irvine, CA
    #7
    Perhaps it might be wise to uninstall Better Gmail. There is also a Better Gmail 2...perhaps this is the correct version you should be using. Just a thought. Good luck! I do not use either one and have been trouble free so far. Linda
     
  8. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #8
    No, that isn't the problem. I use the latest Better Gmail 2 version and I don't have any problems with my other 3 Gmail accounts.

    It's highly frustrating that nobody seems to know what's causing the problems, let alone any solution.
     
  9. ElBerserko thread starter macrumors member

    Joined:
    Jun 30, 2007
    #9
    I've never used Better Gmail at all and I have the problem. It must be a problem on Google's side related to specific accounts. Also, I have noticed in Mail.app the most recent message acts strangely. It will mark itself as read even without reading it and that change is never reflected in the gmail web client.
     
  10. Prodger macrumors newbie

    Joined:
    Jan 28, 2008
    #10
    I've never used better gmail either. It must be something on gmail's end, but it's odd how it only affects certain accounts.

    ElBerserko - I haven't encountered that same issue yet, but who knows what might happen in the next few days...
     
  11. AnonymousCoward macrumors newbie

    Joined:
    Sep 26, 2007
    #11
    I been having a similar problem, I can never get ANY new mail into the inbox from Gmail IMAP. Started happening a few days ago.

    Really wierd because prior to this I had a totally different problem. The oldest message in my Gmail inbox would never show up in the mail app on the iPhone. So it was always showing one less than the total messages in my inbox.

    All of my other folders work properly. The inbox doesn't work at all.

    Very, very frustrating and annoying. Google needs to get it together :mad::mad::mad:
     
  12. ElBerserko thread starter macrumors member

    Joined:
    Jun 30, 2007
    #12
    This appears to be working again for me. Anyone else with the problem notice that it is now working properly?
     
  13. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #13
    Negative here. Still the same problem- very, very annoying.

    For those people who have the problem with their Gmail account (this refers to retrieving emails via IMAP), please report the issue to Google here.
     
  14. ElBerserko thread starter macrumors member

    Joined:
    Jun 30, 2007
    #14
    The fix was short lived for me. It is now back to having the same problem. I was starting to fill out that form yesterday when I saw that my problem seemed to have gone away. Guess I will fill it out again.
     
  15. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #15
    Has anything changed for you guys? Problem fixed or does it persist? My iPhone still doesn't get the most recent email.
     
  16. JRL macrumors newbie

    Joined:
    Feb 2, 2008
    #16
    I too am having this problem. Hopefully someone has some answers soon. I can't figure it out at all, I've deleted my account on my iPhone and recreated it. Also before I noticed this happening, I had one email that would not change to unread status at all. Weird things...
     
  17. ElBerserko thread starter macrumors member

    Joined:
    Jun 30, 2007
    #17
    It has been fixed for me since yesterday. I sent a support request to Google and they replied back asking for some more info. About a day after that I haven't been having any problems.
     
  18. targus macrumors newbie

    Joined:
    Jan 29, 2008
    #18
    IMAP Problems

    Hi everyone,

    I`m having a lot o trouble trying to use IMAP on my Iphone
    Recently I changed my pop account for a Imap one.
    In my MBP everything works fine but in my 1.1.2 jailbroken iphone I can`t make it work
    I configure everthing as the same in My MBP and I keep receiveing the message: " Cannot get mail the connection to the server imap.com failed.
    the strange thing is that i can see all my folders but can`t see any message.
    Does anyone had/has a problem like this one? Does anyone knows how to fix it?
    I have no more ideas, I have already deleted the account several times and the error still the same
    My IMAP server do not use SSL and everything seems to be ok in the iphone.
    I also tried to sync with itunes to get the same configurations from my MBP, but it didn`t work too.
    I`ll appreciate any help
     
  19. Akira1980 macrumors 6502

    Akira1980

    Joined:
    May 27, 2007
    Location:
    San Diego
    #19
    If you are having problems with IMAP, try restoring the iPhone through iTunes. Then sync your mail accounts through iTunes. (NOT adding it manually) I had problems with Gmail IMAP before restoring the iPhone, but after I reset everything it works great.
     
  20. Ometochtli macrumors newbie

    Joined:
    Feb 6, 2008
    #20
    For now, I just set my gmail account to forward email to one of my working accounts (in the Forwarding & POP/IMAP section) Seems to be working so far.

    Has anyone tried a restore per Akira1980's suggestion? I'll probably try it tonight and report back.

    jt
     
  21. iTiki macrumors 6502

    Joined:
    Feb 9, 2007
    Location:
    Maui, Hawaii
    #21
    I just started having the same problem. Sorry I started another thread before doing a search. This sure drives me nuts. Going to try the restore tonight,:mad:
     
  22. targus macrumors newbie

    Joined:
    Jan 29, 2008
    #22
    No goog

    I tried restoring the Iphone to 1.1.1 by Itunes and syncronyzed email accounts and I had the same problem that before I can see the Imap folders but not the messages.
    What it is strange is that I create a Gmail account to check the IMAP service from another ISP, and it worked fine.
    I can´t understand what happens with my paid ISP, if anyone has any ideas
    I'm all ears:confused:
     
  23. Ometochtli macrumors newbie

    Joined:
    Feb 6, 2008
    #23
    I took ghettochild's advice and reported this to google - they replied with this within a couple of hours:

     
  24. iTiki macrumors 6502

    Joined:
    Feb 9, 2007
    Location:
    Maui, Hawaii
    #24
    I got the same response. Hoping for a quick fix.
     
  25. moel macrumors 6502

    Joined:
    Nov 7, 2007
    #25
    i've got the same problem too..

    someone delete 'phones' obviously a twat
     

Share This Page