iPhone doesn't connect to wifi

Discussion in 'iOS 5 and earlier' started by Bahaa-AZ, Nov 2, 2011.

  1. Bahaa-AZ, Nov 2, 2011
    Last edited: Nov 2, 2011

    Bahaa-AZ macrumors newbie

    Joined:
    Oct 23, 2011
    #1
    I got a new router a month ago and was using my iphone 4 (IOS 4.3.3) and everything was fine. When I updated my iphone to IOS 5.0 and jailbroke it, it started acting weird with my wireless network, and by weird I mean it doesn't connect to my router when I ask it, instead I have to leave it and wait for it to connect on it's own, which sometimes doesn't happen for longer than a day. Usually when it connects it stays connected for as long as I'm in the wifi's range, but when I leave home and come back later, it won't connect. Sometimes it connects for a few seconds then it disconnects. I figured the problem was caused by the lease time (set to 2 hours), it restarts almost as soon as my phone connects. I tried doing a lot of things (updated my router, restarted my phone, turned off wifi then back on, rebooted router, forgot the network then added the password and everything again) and nothing worked. My macbook pro and my roommate's laptop connect with no problems, but both our iPhones 4 (IOS 5) don't (his iPhone isn't jailbroken). Any help would be much appreciated.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. Bahaa-AZ thread starter macrumors newbie

    Joined:
    Oct 23, 2011
    #3
    If this may help I have a TP-Link router with the latest version (7).
     
  4. number84 macrumors 6502

    Joined:
    Mar 30, 2011
    #4
    Not sure if related, but I've had issues with iOS devices in the past when my router had QoS enabled. Try disabling that and see if it helps any.
     
  5. srcstc macrumors member

    Joined:
    Oct 22, 2010
    #5
    I've noticed mine doing exactly the same thing.
     
  6. Bahaa-AZ thread starter macrumors newbie

    Joined:
    Oct 23, 2011
    #6
    QoS already disabled, it worked yesterday for me when I rebooted my router, but now after trying to reboot 2 times, it still won't connect.
     
  7. Thetonyk123 macrumors 68000

    Thetonyk123

    Joined:
    Aug 14, 2011
    Location:
    Earth
    #7
    Have you tried to reset your router?
     
  8. Bahaa-AZ thread starter macrumors newbie

    Joined:
    Oct 23, 2011
    #8
    I didn't try reseting it, but I did update it to the latest version, thinking this may solve the issue (I think this is equivalent to reseting) but it didn't. The only way it seems to work for me is rebooting the router a number of times until it works. It's driving me crazy, could it be a bug in IOS 5?
     

Share This Page