iPhone doesn't wanna change country!

Discussion in 'iOS 6' started by scyap, Jan 15, 2013.

  1. scyap, Jan 15, 2013
    Last edited: Jan 15, 2013

    scyap macrumors member

    Joined:
    Dec 22, 2010
    #1
    Hi guys, my iPhone 5 is running iOS 6.0.2 and was bought in Australia, I've been using it happily in Australia, loading stuff that uses Internet connection was pretty fast without hiccups.

    and now I've returned to Malaysia,my home country, and found that my phone is incredibly slow when loading anything that requires Internet (cellular/WiFi)

    Even my friend's 4S is much faster.

    When I open WhatsApp, it takes about 3minutes to get connected
    When I open the FB app, it takes about 5-10min to load the news feed, this doesn't include updating my notifications/messengers list yet.
    I'm also unable to send any messages through the FB msgr app
    Loading webpages are almost impossible, just like trying to load any mail
    Searching a simple mail on server took me about 35 minutes

    AND THEN........
    I found out this morning that whenever I use Google search, i WILL be directed to the Australia site (we do have a Malaysian google site)

    When I say Google search, I mean...
    - Spotlight search and tapping on "search the web"
    - Safari search textbox at the top right corner
    - Chrome's search at the URL textbox

    It seems that my phone is only trying to connect to Aus google sites, I wonder if it's also happening for my other apps?
    Like, trying to connect to Aus first?

    We have no Apple store here so we're pretty screwed :(

    It is worth noting that my cellular & WiFi networks are pretty decent and not very crappy. My friend's 4S on the same WiFi network took 1-2 seconds to connect while mine took at least 3minutes
     
  2. garybUK Guest

    garybUK

    Joined:
    Jun 3, 2002
    #2
    Did you change sim cards to a local carrier?

    Under settings -> general -> profile is it still going through your Australian APN? you could try resetting network settings or selecting another network manually and then re-setting it? Is the wifi broadcasting the correct country? etc.

    might all be dead ends but worth a try.

    Also maybe the regional settings might need to be set.
     
  3. scyap thread starter macrumors member

    Joined:
    Dec 22, 2010
    #3
    I don't have a Profile option, probably because I have no profiles at all.
    Tried network reset prior to posting this, didn't work at all.
    I don't understand what you mean by "WiFi broadcasting in the correct country"

    Changing the region worked, thanks!!!
    I'll be testing if my Internet is still slow
    Thanks again!
     

Share This Page