iPhone drivers don't install...?

Discussion in 'iPhone' started by GlassBullet, Sep 26, 2009.

  1. GlassBullet macrumors regular

    GlassBullet

    Joined:
    Jul 7, 2009
    Location:
    Ventura, CA
    #1
    Whenever I plug in my iphone 3gs to my computer, it says that the drivers failed to install. It shows up in itunes, but no in my computer. I'm running 3.0 and I did the restore trick the saurik posted. It has worked on this computer before, but not since i installed itunes 9.0.1. what should i do to fix this problem?

    btw, i have a pc running vista. Come to think of it, I installed Service Pack 2 today also, could that be part of it?
     
  2. Ace134blue macrumors 6502a

    Ace134blue

    Joined:
    Sep 17, 2009
    #2
    Is it jailbroken? Also if nothing works i would restore the phone.
     
  3. GlassBullet thread starter macrumors regular

    GlassBullet

    Joined:
    Jul 7, 2009
    Location:
    Ventura, CA
    #3
    yeah it's jailbroken. but it works with itunes and i can sync and everything, it just doesn't show up on the computer
     
  4. GlassBullet thread starter macrumors regular

    GlassBullet

    Joined:
    Jul 7, 2009
    Location:
    Ventura, CA
  5. sinsin07 macrumors 68030

    Joined:
    Mar 28, 2009
    #5
    what device driver are you talking about? The USB driver? If the answer is yes have you gone to devices in Computer Management. (see screenshot) Also have you run the Itunes diagnostic?
     

    Attached Files:

Share This Page