iPhone earpiece/speaker problem????

Discussion in 'iPhone Tips, Help and Troubleshooting' started by djdvaleting, Apr 20, 2008.

  1. djdvaleting macrumors newbie

    Joined:
    Apr 20, 2008
    #1
    I realise this has been posted a 1000 times but I think my issue is slightly different.

    My speaker works perfectly when I recieve an incoming call, I can hear tones when I type in a number on the keypad. But when I make a call I can hear the dial tone but as soon as I am connected to the person Im calling I cannot hear anything and they cannot hear me. I have to activate speakerphone and then turn it off to make the earpiece work.

    I have tried most of the suggestions such as plugging and unplugging the headphones, reseting, blowing in the head phone jack ect ect.

    Surely if the phone thinks that the headphones are connected then it wouldn't matter if I were making or recieving a call?

    I have updated the firmware to 1.1.4 but recently went back to 1.1.3.

    Any help would be much appreciated!
     
  2. VenomousSVT macrumors 6502

    Joined:
    Dec 4, 2007
    Location:
    Charlotte, NC
    #3
    that definitely sounds like a different issue than the typical headphone issue. Did this issue become apparent right after the downgrade? It sounds almost like it is trying to default to the outside source, like a BT device, even if there isnt one present. Try disabling BT and giving it another try. If this doesnt work I would suggest doing a sync then restoring the phone.
     

Share This Page