iPhone Email Configuration - Advice Please

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JamboUK, Aug 12, 2008.

  1. JamboUK macrumors member

    Joined:
    Jul 12, 2007
    #1
    Hi,

    My main email account is a Googlemail account which I find suits my requirements. The only thing, it doesn't do it "Push".

    So I have set up a Yahoo mail account and then configured Googlemail to forward all incoming email to this account and so therefore pushes to my phone.

    BUT when I write an email from my iPhone it is shown as coming from an username@yahoo.com email address where as I would like it to show my primary username@gmail.com email address and therefore people reply to that!

    Is it possible to set up such an alias on the iPhone? Anyone achieve something similar? All help appreciated.
     
  2. manchoi44 macrumors member

    Joined:
    Feb 1, 2008
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5B108 Safari/525.20)

    I use a similar workaround with my gmail being forwarded to my mobile me. Just manually change the SMTP (outgoing server) to reflect the settings of gmail (I believe it is: SMTP.gmail.com using your username and password to authenticate, on port 587, using SSL)
     
  3. JamboUK thread starter macrumors member

    Joined:
    Jul 12, 2007
    #3
    Thanks - this will also display my return address as username@gmail.com?
     
  4. manchoi44 macrumors member

    Joined:
    Feb 1, 2008
  5. haddman macrumors regular

    Joined:
    Aug 1, 2008
    #5
    This works with mobileme but not yahoo accounts. Yahoo will not let you turn "off" the yahoo smtp server. The only way from what I see to do this with yahoo would be to leave both your google and yahoo accounts turned "on" and then you have to manually switch witch account your sending from when replying. I love gmail but it pisses me off they don't have push mail for the iphone.
     
  6. moc67 macrumors newbie

    Joined:
    Aug 12, 2008
    #6
    Does this change the "from" field of your outgoing email to your non-me.com account?

    I have an email account forwarded to me.com (because the account cannot push). I can't seem to make the non-me account the default "from" address when replying to email forwarded to me.com.

    The outgoing smtp settings for me.com are greyed out so I cannot change them. I do have the option of turning off the outgoing me.com smtp and using my non-me smtp, but the "from" field is still me.com by default.

    I hope I'm missing something. If so, can you please explain how you do this.

    Thanks.
     
  7. JamboUK thread starter macrumors member

    Joined:
    Jul 12, 2007
    #7
    Back to GoogleMail for me then and let it Fetch every hour. Shame about 'Push' but Googlemail works for me as a whole.
     
  8. haddman macrumors regular

    Joined:
    Aug 1, 2008
    #8
    you have to add your Gmail account to the phone and then just set it to "off" in the mail settings. once you have the account loaded, go into your mobile me mail settings on the iphone, turn off the primary me smtp server, and down below turn "on" the gmail smtp server. Whith the primary server off, it will default to the first alternate, and your replies will be sent using your gmail address. Also, items sent will show in noth you mobileme and Gmail sent folders.
     
  9. haddman macrumors regular

    Joined:
    Aug 1, 2008
    #9

    Same here. I was using the mobileme for push and fowarding my email. But it is just too big a pain to keep up with both boxes. I thought about completley switching to yahoo or me but would rather stick with my gmail account. I love most of googles products and services, just can't understand why they don't offer push email for the iphone.
     
  10. moc67 macrumors newbie

    Joined:
    Aug 12, 2008
    #10
    Maybe it's just a difference between gmail and my non-me account, because even when I do this, the default "from" field is still my me.com account.:(

    Thanks anyway
     
  11. haddman macrumors regular

    Joined:
    Aug 1, 2008
    #11
    Have you even tested this?? Yes the defualt from account SHOULD SAY ME.COM!! If you have the me.com smtp server set to off and the gmail smtp server turned on it will use your gmail to send, and folks receive emails it will show from your gmail address, not your me.com.
     
  12. moc67 macrumors newbie

    Joined:
    Aug 12, 2008
    #12
    You will be shocked to learn that before posting that something didn't work for me, I actually tested to see if it worked. I could capitalize and double-punctuate it for you if that helps.

    As I wrote (and you quoted) my non-me.com email is not gmail. I don't know enough to know if that matters.

    I'm not calling you a liar or saying you're wrong. I'm just saying it's not working for me. I go into settings, turn off my non-me account, turn off my me.com outgoing mail server, turn on my non-me outgoing server, send an email, and the recipient sees "from" my me.com address.

    I'm open to guidance if I'm doing it wrong (and I'm completely open to fact that I may be). Nothing to get testy about.

    Thanks, though, for your previous how-to posts.
     
  13. vilasgn macrumors regular

    Joined:
    Aug 12, 2008
    #13
    I agree with you on "Maintaining both mail boxes is a pain". I wish there was some way to sync gmail as we use mobile me on Phone.
     
  14. Acejam2k macrumors regular

    Joined:
    Jul 16, 2008
    #14
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5C1 Safari/525.20)

    Just use gmail IMAP. Is it really that bad having to wait 15 min for an email?
     
  15. parham55 macrumors member

    Joined:
    Feb 10, 2008
    #15
    I'd really like to see user definable fetch periods less than 15 minutes.
     
  16. aido macrumors newbie

    Joined:
    Nov 4, 2007
    #16
    You've set up the gmail to forward on your messages to yahoo right.
    So yahoo pushes these mails to your iphone.

    Add your gmail account to your iphone, and simply check for mail in gmail when yahoo pushes them to your phone.
    The mail should appear in your gmail account, and you can reply from there.

    Should work, good luck
     

Share This Page