iPhone Email Unreliable - Especially Sending

Discussion in 'iPhone' started by Skaught, Oct 16, 2008.

  1. Skaught macrumors member

    Joined:
    Jun 12, 2003
    #1
    My iPhone seems to have issues where POP email is concerned. Signal strength doesn't matter, nor does Edge or WiFi. Quite often it will simply spin and spin as it tries to download email. When it does download something, it won't load it when I open the email (spins its wheels while trying to open the contents until I get the "not downloaded" message). Even though the preview shows the first part of the email text. What's up with that?

    When it comes to sending, I'll have an outgoing message in the outbox for most of the day before it finally sends. No error messages, it just decideds to quit trying.

    I have no problem downloading email on any of my PCs. Heck, if I log in to my web-based email script, I can read the email on my iPhone that way. So there's nothing wrong on my email server's end.

    So what's up with Apple making such a lame email system?

    Scott
     
  2. Loonytik macrumors 6502a

    Loonytik

    Joined:
    Jun 2, 2008
  3. mutantblack macrumors regular

    Joined:
    Oct 8, 2008
  4. mattocs macrumors member

    Joined:
    Oct 6, 2008
    #4
    My phones email, yahoo via push, will send messages 3 or 4 times, sometimes hours after I sent it.
     
  5. friekunater macrumors 6502

    Joined:
    Mar 8, 2008
  6. deimos256 macrumors 6502a

    Joined:
    Sep 9, 2008
    #6
    i used to have the problems the OP describes, not quite to the same extents such as email sending a day late, more like 15 minutes or so, but after 2.1 i havent had any email issues, except my phone doesnt fetch when im sleeping. Once i wake up itll say i have no emails and about a minute later they all show up
     
  7. iMetalG5 macrumors 6502a

    Joined:
    Apr 13, 2005
    #7
    mine is fine. but i was at the apple store tonight and some girl was talking to a genius about the same thing. i think all they did was check the settings of her POP and changed stuff and she started clapping so i assumed they figured it out...
     
  8. friekunater macrumors 6502

    Joined:
    Mar 8, 2008
    #8
    ??
     
  9. eRondeau macrumors 6502a

    eRondeau

    Joined:
    Mar 3, 2004
    Location:
    Canada's South Coast
    #9
    Switch to IMAP. I had the same problems when I was set for POP, then I switched to IMAP and now it's working great. :apple:
     
  10. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #10
    +1 ^^^ IMAP is the only way to go for me as well...:cool:
     

Share This Page