iPhone + Emoji + MacOSX Mail = trouble with encoding

Discussion in 'iPhone' started by aforty, Aug 23, 2009.

  1. aforty macrumors 65816

    aforty

    Joined:
    Nov 27, 2007
    Location:
    Brooklyn, NY
    #1
    Hey guys.
    Have this issue. I will start a email thread on my iPhone an include some emoji icons with it. When I then go to my computer and try to reply to the email (that has the emoji in it) I get this error upon sending:

    Invalid Text Encoding
    Some characters in your message could not be converted to the “Japanese (Shift JIS)” text encoding. Please choose a different entry from the “Text Encoding” menu.

    Seems that the only solution is to manually remove the icons (which show up as boxes in MacOSX) before sending. Anyone have a easier solution that might not require me to go through a 15 replied emails and remove emojis?
     
  2. gilkisson macrumors 65816

    gilkisson

    #2
    That is interesting. I'll try that right now.

    My first thought would be, do you have Japanese language support installed on your Mac, or did you nuke the other languages (like I did) to save some disk space?
     
  3. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #3
    computers cannot understand emoji, so there is no point in trying to email using them. they all need to be deleted
     
  4. PhightinPhils26 macrumors 6502a

    PhightinPhils26

    Joined:
    Sep 12, 2007
    Location:
    Philly
    #4
    It's to my understanding that iPhone Emoji icons can only be seen on other iPhones.
     
  5. aforty thread starter macrumors 65816

    aforty

    Joined:
    Nov 27, 2007
    Location:
    Brooklyn, NY
    #5
    Didn't even know you could fully nuke other languages from the system. Where would I find out? I checked in Preferences --> International but that only appears to be a list of languages supported, which does include Japanese for me.

    I get that I'm not going to actually "see" the emoji on my computer, I'm not expecting it to. But I'm not going to stop using them because the other person does use her iPhone all the time and will see them. My only issue is with having to go through the entire email thread every time and delete the emoji before sending. There has got to be a better way.
     
  6. gilkisson macrumors 65816

    gilkisson

    #6
    http://monolingual.sourceforge.net/

    It doesn't save a ton of space, but it does do a bit...
     
  7. aforty thread starter macrumors 65816

    aforty

    Joined:
    Nov 27, 2007
    Location:
    Brooklyn, NY
    #7
    Hmm ok, well I definitely didn't run that beforehand. So I have all languages installed.
     
  8. gilkisson macrumors 65816

    gilkisson

    #8
    Like the Phils up there said -- it's on your phone only. I just tested it myself, got the same results.
     
  9. Pika macrumors 68000

    Pika

    Joined:
    Oct 5, 2008
    Location:
    Japan
    #9
    Try: [app]Emoji Mailer (emoji to desktop Email)[/app]
     
  10. aforty thread starter macrumors 65816

    aforty

    Joined:
    Nov 27, 2007
    Location:
    Brooklyn, NY
    #10
    You guys completely missed the point it seems.

    The solution was to set the encoding on the message to UTF-8. Problem solved.
     
  11. gilkisson macrumors 65816

    gilkisson

    #11
    Well then, congratulations on solving your problem. As you are the one with the fullest understanding, it's right and proper that you figured it out to your own satisfaction.

    Now. How about them RedSox, huh?
     
  12. aforty thread starter macrumors 65816

    aforty

    Joined:
    Nov 27, 2007
    Location:
    Brooklyn, NY
    #12
    Thanks :)

    As for the Redsox, the division is over, better concentrate on the wildcard. :rolleyes:
     

Share This Page