iPhone error 9. Unable to restore... Please help

Discussion in 'Jailbreaks and iOS Hacks' started by Perthpunker, Dec 19, 2009.

  1. Perthpunker macrumors newbie

    Dec 19, 2009
    ok so let me start off by saying i did search the threads but couldn't find any solutions that worked.

    I have a 16gb iPhone 3gs running 3.1.2 that i just JB last night, today i downloaded a theme from Cydia and my phone tried to restart but would not load. I put it into restore mode and I tried to do a restore through iTunes to no avail, it gets to the point where the phone shows the apple with the load bar, but it doesn't load it just comes up with an error saying...

    "The iPhone could not be restored. An unknown error occurred (9)."

    I have tried to restore it in DFU mode as well, but still get the same error.

    I have tried to restore with my custom fw made with pwnage tool, I've tried the original 3.1.2, 3.0.1 and 3.0. When trying 3.0 and 3.0.1 i got an error saying "This device isn't eligible for the requested build". I also tried to restore on a windows machine...

    can anyone help? If i took it into NextByte or 3 mobile to get it swapped out/repaired could they tell that it was JB? I didn't use the custom boot/restore logos so if they cant restore it then they wont know?

    Any help/suggestions would be greatly appreciated


    Never mind took the phone in and got it swapped out for a brand spankin new one!
  2. refeist macrumors newbie

    Jan 11, 2010
    One trick

    I had the same problem and discovered a fix by applying a solution to a similar but different problem. Turn off the iPhone and remove the sim card. Then hook to iTunes and restore. After restoration, insert sim card, and resynch.

    If the problem returns you have either a piece of software that's kluging a register (bad) or a intermittent hardware problem (worse). If the problem returns, I'd take it to the AT&T store where you got it or contact Apple direct if you got it on-line.
  3. thelatinist macrumors 603


    Aug 15, 2009
    Connecticut, USA
    I would guess that you have a tethered jailbreak. Read all about it in this thread.
  4. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    I agree. Sounds like new bootrom so he will have tethered jailbreak.
  5. Enzora macrumors newbie

    Feb 12, 2011
    I had the same problem error (9) but fortunately I managed to restore it after countless times of attempt. My phone was previously running on a jailbroken firmware 3.1.3, I followed whatever troubleshooting tips available on apple support site such as upgrading iTunes to the latest version, changing USB port, etc, but it just won't work. So this is what I did -

    (I am using OS Win XP)

    1. Unplug your phone and standby at DFU mode
    2. Go to Control Panel > Administrative Tools > Services
    3. Select 'Apple Mobile Device'. Stop the service, and then start the service again
    4. Close all windows applications
    5. Plug in your iPhone
    6. Start your iTunes if it doesnt auto start
    7. Go to 'Edit' > 'Preferences' in iTunes
    8. Go to tab 'Devices', and click on 'Reset Sync History'
    9. Proceed to restore

    To ensure a smooth restoring process, try not to open other windows applications. Please note that you may encounter Error (9) again, especially towards the last stage of restoring your phone. If this happens, observe the progress indicator on your iPhone screen and see whether or not the progress indicator is still moving. If the indicator is moving, DO NOT shut down or unplug your phone. You may ignore the error and close your iTunes since there's no more communication between your phone and iTunes. At this point, you may encounter 3 scenarios:

    1. Progress indicator is moving smoothly toward completion. Let it run until your phone reboot by itself.
    2. Progress indicator shows completion, but it is stuck for long time without rebooting. Do a manual reboot by holding down start and home button.
    3. Progress indicator doesn't move at all for long time. If this is the case, I m afraid you have to do it all over again (step 1 to 9).

    I encountered the 3rd scenarios several times. Don't give up. Try at least a few times before you find other solutions.

    Hope it helps :)

Share This Page