iPhone, Exchange & Entourage sent mail - solution

Discussion in 'iPhone Tips, Help and Troubleshooting' started by E3BK, Jul 5, 2009.

  1. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #1
    I'm assuming that email sent from the phone should sync w/ the Exchange server, right? What I'm seeing in my Sent mail folder on Entourage isn't exactly the email that I sent from the iPhone. I never noticed this before since I've only been using Exchange on my iPhone recently.

    Is there some setting I'm missing? I need to make sure there is a copy of the emails I send.

    Basically, no matter the message, there is no to/from or subject info. The body of the msg is just plain text stuff that looks like this:

    Code:
    X-MimeOLE: Produced By Microsoft Exchange V6.5
    Received:  from 1xx.xx.xx.xx ([1xx.xx.xx.xx]) by 
    server.info.com ([1xx.xx.xx.xx]) with Microsoft Exchange Server HTTP-DAV ; Sun,  5 Jul 2009 19:10:42 +0000
    MIME-Version: 1.0
    Content-Type: text/html;
    	charset="iso-8859-1"
    
    edit: I logged into OWA and it looks like the sent mail *is* there but why doesn't it show in Entourage?
     
  2. E3BK thread starter macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #2
    So maybe no one else had this problem? Anyway, if you do, I did more digging and found a good explanation and solution here:

    Basically, you should
    -download this Applescript
    - install the file in ~/Documents/Microsoft User Data/Entourage Script Menu Items
    - Create a Rule
    If:
    Specific Header-MAIL FROM: -Contains- your.email@company.com

    Then:
    Run AppleScript-Script-Fix iPhone Sent Mail.scpt (or whatever you named the script)


    Hope that helps anyone who has had this problem as well.
     

Share This Page