iPhone firmware 2.2 : what are my options for unlocking?

Discussion in 'Jailbreaks and iOS Hacks' started by mesamac, Mar 9, 2009.

  1. mesamac macrumors member

    Joined:
    Feb 23, 2008
    #1
    I have 3G iPhone. I closed my contract with AT&T 4 months back. It has 2.2 version firmware. I really would like to "unlock" so that I can use any SIM card if I travel international for GSM network.

    I tried PwnageTool yesterday but not successful. It says "not able to get to DFW mode". I have following questions?

    1. Can we unlock 2.2 firmware iPhone 3G phones?
    2. If I have to only unlock SIM, what should I use? Is it PwnageTool or QuickPwn?
    3. When I trying PwnageTool, while I was asked to power on or hold home button on iPhone, I see that iTunes is getting connected to iPhone while I am using PwnageTool. Will that create a problem and is that why I see that error?

    I really appreciate if you can give some suggestions.. All I would like to do is to unlock the phone. I thought it is easy but some how i am not successful.

    Thanks.
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
  3. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #3
    Let me guess, 10.5.6? If so, DFU is disabled. You will need a powered usb hub to fix this. This is only for Mac OS X 10.5.6.
    If you use Windows, I don't know what the problem is. If I were you, I would try to use QuickPWN and see if that works.
     
  4. DannyBres macrumors 65816

    DannyBres

    Joined:
    Oct 30, 2007
    Location:
    UK
  5. mesamac thread starter macrumors member

    Joined:
    Feb 23, 2008
    #5
    Oh ok. I just now checked and I am using Mac OS 10.5.6. I didn't know that it had some issues with DFU.

    I will try connecting with powered USB.

    For QuickPwn, I thought if i have firmware 2.2 I can't use this as per:

    "1. GOLDEN RULE: If you have a 3G iPhone running 2.2 firmware and you want to keep your ability to use yellowns0w (or the option to use it in the future) do NOT use QuickPwn, and do not use the official ipsw or the iTunes update process without using PwnageTool."
     
  6. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #6
    That was BEFORE they released yellowsn0w. The baseband that 2.2 comes with is the ONLY one which yellowsn0w (the iPhone 3G soft-unlock) can be used on. Go ahead and Pwn your iPhone 2.2.
     
  7. mesamac thread starter macrumors member

    Joined:
    Feb 23, 2008
    #7
    Thank you very much for your comments.

    I tried yesterday QuickPwn but and it gives me error when I run and connect,
    it says the firmware 2.2 is not supported and I only had to quit from that.

    I wonder what I am missing.. I really appreciate if you can help me unlock the phone.

    Thanks.
     
  8. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #8
    There is a different release of QuickPwn for each firmware. You need to find the 2.2 version.
     
  9. mesamac thread starter macrumors member

    Joined:
    Feb 23, 2008
    #9
    Oh great and thanks for the information.

    I didn't pay attention to the QuickPwn version for iPhone 2.2 firmware
    to it. Some how I happened to pick from top of the URL list.

    I will try it out today evening...

    Just a note, for beginner like me, it's very confusing on QuickPwn, Pwnage, yellowsn0w etc.
     
  10. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #10
    I can see where you would get confused.
     
  11. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #11
    Bascially...

    QuickPwn: A tool for Jailbreaking iPhone, iPhone 3G, and iPod Touch 1st Gen. It can also unlock the iPhone 2G. It's the most simple and quickest form of Jailbreaking, but lacks many options and customization. You can install Installer and Cydia onto the device. There are both Mac and Windows versions.

    PwnageTool: A tool that you can make a custom firmware file with. It offers more options than QuickPwn, including preserving the baseband. It can Jailbreak the iPhone, iPhone 3G, and iPod Touch 1st Gen, and unlock the iPhone 2G. You can install Installer and Cydia onto the device, and also other packages. Once you've made the custom firmware, you can load it onto your phone from iTunes. Only for Mac

    Yellowsn0w: The software unlock for the iPhone 3G. It only works with the 02.28.00 baseband, which came with the 2.2 firmware. It's installed via Cydia.

    Hope that helps :D
     
  12. mesamac thread starter macrumors member

    Joined:
    Feb 23, 2008
    #12
    Thank you so much. It's very clear now :)

    Now that you explained in detail on these software, I might only need
    Yellowsn0w to unlock on iPhone 3G with 2.2 Firmware on it.

    I will try installing via Cydia and if I am not successful then I will
    install QuickPwn iPhone 2.2 firmware version.

    Thanks.

     
  13. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #13
    Cydia (and therefore Yellowsn0w) is only accessible on jailbroken phones. You can't unlock without jailbreaking (with QuickPwn) first.
     
  14. mesamac thread starter macrumors member

    Joined:
    Feb 23, 2008
    #14
    Not able to make progress

    Sorry guys to ask this help again but yesterday's I tried again searching for QuickPwn to see if I can get for iPhone 2.2 firmware version but all I can find is only QuickPwn_2.2.5.dmg.

    I admit that I am very new to these tools and would someone please list what I should do: If you can provide some URL on images to be downloaded that will be a great help.

    I did find some 2.2 firmware with .ipsw format. I downloaded it but when I double it, my iTunes gets open. While we try to Jailbreak, do we need to use iTunes as well?

    Sorry for asking basic questions. I really appreciate if someone can list 1, 2, 3 steps to jailbreak my iPhone 3G Firmware 2.2 version.

    Thanks a lot.
     

Share This Page