iPhone first gen. PUSH help!

Discussion in 'iPhone' started by fireshot91, Aug 5, 2008.

  1. fireshot91 macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #1
    i got the first gen. iPhone, i posted a thread about this, but it really didnt work...
    my PUSH is NOT working, all my settings are on for PUSH, im in wi-fi, and i get 5 bars of service...im using a Yahoo! mail account, with the default server. i sent an email from my GMail and my Hotmail at the same time, about 10 mins ago. i STILL have not recieved them on the phone...its really getting me bugged, because when i found out i can push the mail STRAIGHT to my phone, i told everyone to email me instead of txt me..i only have 200 txts a month :(
     
  2. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
  3. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
  4. jeraldobunkster macrumors newbie

    Joined:
    Aug 2, 2008
    #4
    Did you upgrade to 2.0.1? Cause I am having the same situation after I upgraded and its not receiving my emails, and will "check" for new emails forever and nothing new appears.
     
  5. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #5
    yes i upgraded to 2.0.1, but its not that its searching for mails, its supposed to continuesly search for mails...the PUSH function is on...i get the mail within 30 secs. if some1 from Yahoo! sends me an e-mail to my phone...but if some1 from g-mail/hotmail or any other service thats not Yahoo!, i dont get it, untill i manually search for it...this is not good....it was there in 2.0.0 to
     
  6. DenniZ macrumors 6502a

    Joined:
    Oct 5, 2007
    Location:
    Liverpool, UK
    #6
    Try deleting the account on your phone, and set it up again on your phone might do the trick.
     
  7. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #7
    k but BEFORE i posted that post above yours, i sent a mail from my g-mail to the yahoo thats linked to my phone..i STILL did not get it, that was like what 10-15 mins ago?, im going to try to delete the acc. and then add it again.
     
  8. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #8
    ok, i just deleted my acc off the phone, now i added it, im going to try sending myself an e-mail from my g-mail, but as soon as i added the account back, i got that first email i sent my self..(i think its because it searches right once you add a new acc)


    EDIT: i got that g-mail in about 8 seconds...(i was counting lol) i think its working now!!! THANKS!
     
  9. DenniZ macrumors 6502a

    Joined:
    Oct 5, 2007
    Location:
    Liverpool, UK
    #9
    Lol, I know how you felt, after I read your thread, i tested my own as well, and suprise suprise it didnt work until i deleted and added the account again on the phone lol.
     
  10. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #10
    lol, yeah, stupid mail on iPhone isnt as good as BB
     
  11. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #11
    -_-. i tried another e-mail from gmail.com.....guess what...DIDNT WORK!!! stupid stupid phone..its awseme, but it lacks a lot of childish phone stuff


    EDIT: i cant keep on deleting and adding my account every time i get an e-mail....most of my e-mails are important.., ok no they arent i just want email on my phone..lol, im 14..but seriously, i told people to email me instead of txt me, n now this doesnt work!!!, ughh..i guess i dont want e-mail on my phone then...FORGET YOUR EMAIL SERVIC APPLE!!
     
  12. DenniZ macrumors 6502a

    Joined:
    Oct 5, 2007
    Location:
    Liverpool, UK
    #12
    are you connected to wifi or 3g when you want your emails ?
     
  13. fireshot91 thread starter macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #13
    i got the first gen. but im connected to Wi-Fi, when i did the 'tests' but its fine thx for the help, i dont really need email on the phone
     
  14. rioja macrumors regular

    Joined:
    May 19, 2008
    #14
    Yahoo push only works 50% of the time at best. If it was working for an extended period of time for you, consider yourself lucky.

    My experience with the iPhone has been that the only mail service that gives reliable push is Exchange. I've used it with 2 different Exchange accounts and never had a single problem.
     

Share This Page