iPhone Full of 'Other', Can't Sync

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SaladFork, Jun 30, 2008.

  1. SaladFork macrumors newbie

    Joined:
    Apr 30, 2008
    #1
    I've been using my iPhone for no problem for the past three months, but this morning I accidentally disconnected it while running a backup. The iPhone works fine, but now when I plug it into iTunes it shows me as having 13gb of 'Other' (orange) instead of properly showing my music/videos (see picture below). Also, it doesn't recognize my music or videos on my device as being mine, both showing up as "No Music".

    I didn't know where else to go, and a google search only returned someone on the apple forums telling the person to restore. However, I'm hoping that since mine is jailbroken, there's an alternative method using SSH or something so that I don't have to restore.

    I have a first generation 16gb iPhone that's jailbroken, activated, and unlocked. It's currently on the T-Mobile network. SSH is working great, and all my applications are symlinked. I can SSH/sFTP in if needed, I know how to do all that.

    Here's a screenshot of iTunes showing me what's on my iPhone:
    [​IMG]

    And here's a screenshot of the error I get when I try to sync:
    [​IMG]

    If anyone knows a solution to this (or if you know that the only way to fix this is to restore), please do let me know.

    Thanks in advance!

    ~Salad
     
  2. wackymacky macrumors 68000

    wackymacky

    Joined:
    Sep 20, 2007
    Location:
    38°39′20″N 27°13′10″W
    #2
    suspect that you have corrupted the data on the flash memory while disconnecting whilst it was written too. Much like removing a USB flash drive without un-mounting it first.

    It’s not really a matter of the phone being jail-broken or not but the way the memory works.

    I suspect strongly you will have to restore the phone.
     
  3. alexuser macrumors newbie

    Joined:
    Jul 1, 2008
    #3
    Hey, I heard that the iPhone stores all the email you get as other and never deletes any email messages off the phone, even if you select delete (unless you have changed the settings). Try going to mail settings and tinkering with that.
     
  4. Mobile923 macrumors 6502

    Joined:
    Sep 20, 2007
    Location:
    New York, NY
    #4
    I've been having this problem all morning...

    Reluctantly, I did a restore (took god-knows how long...especially since I didnt have a back up), then an iTunes media resync, and everything seemed to be fine...

    I plugged it in again later this afternoon, all my itunes media was pulled back in as "OTHER"... UGH.

    I am NOT doing this restore and resyncing 16GBs all over again. So, I just found out how to do this WITHOUT restoring:

    (note: i dunno exactly what fixed it, but here's what i did)

    Plug the iPhone in... you'll see all your iTunes data as the orange "OTHER"

    Applications > uncheck sync apps
    Summary Tab > check off "Manually Manage" > Sync

    and auto-magically... the orange "other" capacity status was gone. only photos were left.

    Now I can painfully re-sync without having to restore.
     
  5. pliundemix macrumors newbie

    Joined:
    May 12, 2010
    #5
    When you say "check off" Manually Manage, does this mean to put the check mark in the box? or to uncheck the box?
     
  6. itsnorcal macrumors newbie

    Joined:
    Oct 25, 2013
    #6
    Apply hard reset

    I had a similar problem, my used space(music, movies, apps) all of a sudden showed up with an orange yellow type bar saying other and wouldn't allow me to sync.

    I just applied a hard reset to the iphone(hold down home/lock button) and everything reset to normal. Weird, simple fix though.
     
  7. Jaipaals57 macrumors newbie

    Joined:
    Apr 22, 2014
    #7
    YES!! Thanks you very much man saved my life! (Not literally though) :p All you have to do is unplug your iphone and apply a hard reset (Holding down lock and home button for 10 seconds), plug it back in and everything will show up as normal!

    ----------

    Simply apply a hard reset (holding down home and lock button for 10 seconds) and it should show up with everything. It is wierd and idk why but it worked for me and was so grateful thanks to itsnorcal.
     
  8. JBmaya macrumors newbie

    Joined:
    May 3, 2017
    #8

    I had this exact problem and there was a quick fix.
    Shut down your computer (I have an Apple).
    Shut down (hard) your iPhone (I have an iPhone 6), holding the off button and the Home button down at the same time.
    Wait 30 seconds. Turn you iPhone back on and connect it by cable back onto the computer. Then reboot.
    It worked for me.
    Good Luck.
     

Share This Page