iphone gets wifi, but macbook does not. self assigned ip address...

Discussion in 'Mac OS X Server, Xserve, and Networking' started by theladyashley, Oct 7, 2008.

  1. theladyashley macrumors newbie

    Joined:
    Oct 7, 2008
    #1
    hi all,

    i am temporarily living in austria where it was very impractical for me to get cable/dsl internet installed (it would take six weeks and i'm only here for twelve).

    there is a network in my building that i can access successfully from my iphone (web surfing, email, etc.). this same network shows up on my macbook, but i can't get to the internet because of a 'self assigned ip address.' i have tried copying the iphone's ip for the network over to the macbook to no avail. i don't have access to the router, but i'm assuming there's no problem with the router, since my iphone can get internet just fine.

    any help would be much appreciated... i'm having to use a pre-paid usb modem stick and it is driving me insane.

    thanks!
    ashley
     
  2. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #2
    What kind of signal are you getting from the access point? I've had problems getting an IP when the signals are too low.

    Have you tried moving the system around to see if you get varying results?
     
  3. theladyashley thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #3
    i get about three bars - which should be plenty, since i get less than that in other locations but have no trouble getting an IP. i have tried moving it around - doesn't seem to work.
     
  4. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #4
    Hmm, that's really weird. The only thing I can think of is they have MAC filtering enabled (having your iPhone MAC in there for some odd reason), or there is security enabled and your MacBook isn't configured correctly, and somehow the iPhone is.

    Neither of these seem accurate, but it is really the only thing I can think of.
     
  5. rogair macrumors member

    Joined:
    Dec 1, 2007
    #5
    Try copying down the IP your iPhone gets, and then turning off wifi. Use the IP from the iPhone on your Macbook.
     
  6. fwhh macrumors regular

    Joined:
    Aug 11, 2004
    Location:
    Berlin, Germany
    #6
    Have you tried to delete the network from your recent/preferred network list and connect again? Open the Network Preferences, select Airport, More Options, select the network an press "-", then reconnect to the network.
     
  7. nsbio macrumors 6502a

    nsbio

    Joined:
    Aug 8, 2006
    Location:
    NC
    #7
    I know it sounds silly, but is your firewall enabled? I had exactly the same problem appear after a system crash and the only way to restore internet access was to temporarily disable the firewall (and then re-enable it once the computer is able to connect to the internet).
     
  8. ogee macrumors 6502

    Joined:
    Nov 8, 2006
    Location:
    Earth.
    #8
    Ive seen this problem when

    1. the macbook has a slower/faster wifi than the router
    2. the router is d-link

    try to open a web browser to the router (gateway address) from the iphone and see what type of router it is.
     
  9. ryan9939 macrumors newbie

    Joined:
    Jul 11, 2008
    #9
    spoof the mac address of your iphone onto your mac, and see if that works.
     
  10. theladyashley thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #10
    i've tried all these options and none seem to work.

    ogee, how i know what the router/gateway address is? if the router is d-link does that mean i'm out of luck?
     
  11. theladyashley thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #11
    how, praytell, would i go about doing this? i'm not privy to command line utilities and i can't find another way of going about spoofing the address onto the macbook...
     
  12. deputy_doofy macrumors 65816

    deputy_doofy

    Joined:
    Sep 11, 2002
    #12
    If you have that network saved in your keychain, you might try deleting it from the Keychain Access utility. Before you do that, go to the settings in the iPhone and make sure it is connecting to the network you think it is.
     
  13. fwhh macrumors regular

    Joined:
    Aug 11, 2004
    Location:
    Berlin, Germany
    #13
    Have you tried to manually connect to the network? By clicking on the airport symbol, and select "Connect to other...", and put in the exact networkname, the right encryption for this network (check your iphone for this information. Should be WPA PSK). Check in the "Network Utility.app", if network device en1 has recieved and transmitted data.

    You can find the gateway/router address in the iphone wifi settings, it should be listed somewhere near your ip address. In most routers the address is your ip-address with the last segment replaced by 1. (eg. your address is 192.168.0.5, the router address is 192.168.0.1)
     

Share This Page