iphone getting stuck IN apps, not going back to main screen

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fatalinjection, May 2, 2009.

  1. fatalinjection macrumors newbie

    Joined:
    May 2, 2009
    #1
    Alright, sorry in advance if this is a noob question, but I'm at my wits end here. I've had an iphone for about 2 months now with no issues. Starting today, I began to have an issue. The first thing I noticed was that while sitting at my desk, without touching the phone it kept suddenly lighting up to the 'slide to unlock screen' like it does when you hit the home button...which i hadn't done, nothing was touching the phone.

    Then, when I tried to do things on the phone, I noticed a bigger issue. It would let me go into an app (standard ones like text or settings as well as others like a twitter app, etc.), and would let me do anything inside that app....but hitting the home button would not return it to the main screen! A couple of times I had success holding down the home button for 10 seconds and force quitting it, but that's rare. It mainly just stays in the app and won't do anything else.

    I've tried turning it off and back on, it continued to do that. I hadn't downloaded any new apps recently, but I still tried deleting all of them, didn't work. I tried unchecking the apps as well in itunes and synching, didn't work. So, I restored the iphone and did a sync from the most recent backup, again not synching any of the apps. It's still having the same issue.

    After I put the phone in sleep mode, the home button doesn't wake it, either. I have to hit the sleep key again, only then will the 'slide to unlock' screen come up.

    Can anyone please help me?? :(:confused:
     
  2. jmccullough108 macrumors 6502a

    jmccullough108

    Joined:
    Nov 2, 2008
    Location:
    St. Louis, MO
    #2
    I would try a restore, "If you device is having problems, please restore".
     
  3. fatalinjection thread starter macrumors newbie

    Joined:
    May 2, 2009
    #3
    Like I said above, I did try that. It's the last thing I did before posting here. :(

    Now I seem to get response if I push just a certain section of the home button...so maybe that's the issue? Is that something they replace? I made a genius bar appointment for tomorrow. My only concern is still the fact that it was randomly lighting up without me/anything touching it earlier.
     
  4. fatalinjection thread starter macrumors newbie

    Joined:
    May 2, 2009
    #4
    i realized it was just an issue with the home button, when i hit it in a certain spot, it would respond, but then later on in the night it stopped altogether. took it to the apple store today and they replaced the whole screen since it was under warranty. :)
     

Share This Page