iphone has locked after updating to 3.0

Discussion in 'iPhone' started by abar, Jun 21, 2009.

  1. abar macrumors newbie

    Joined:
    Sep 18, 2008
    #1
    Hi guys,

    i bought a 3g a few weeks ago in hong kong brand new in the box. It worked perfectly in the uk up until now. i have just tried to update the iphone to 3.0 but It has now completley locked :mad: i have tried resetting the phone by holding the home button and the sleep button together until the apple logo comes up, but again it just sais to plug into my mac! every time i plug it in, it comes up with, 'sorry we could not complete your itunes store request, the host is down'. I do not know what to do, any ideas?

    thanks,

    alex
     
  2. abar thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #2
    anyone? am i completley screwed? (until they figure out how to break 3.0)
     
  3. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #3
    If you bought the phone unlocked by the end user, then yes, you're screwed for right now. You can jailbreak an iPhone 3G running 3.0, but you can't unlock it at this time. Soon, though, apparently.

    See here for the jailbreak. May as well get it done...

    http://blog.iphone-dev.org/
     
  4. abar thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #4
    thanks william-sorry i feel like a complete idiot and am gutted

    sorry for my lack of knowledge, but what does jailbreaking do? do i just download the software and then what?

    thanks
     
  5. iMacDragon macrumors 65816

    iMacDragon

    Joined:
    Oct 18, 2008
    Location:
    UK
    #5
    A genuine hong kong retail phone should be fully unlocked, try again later if itunes was having server problems, it should work.
     
  6. abar thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #6
    yer it was fully unlocked for the previous version software

    but i have obviously made a huge mistake trying to update it :(

    how will jail breaking it, get it out of being locked?

    i guess i'll have to wait until they figure out how to unlock 3.0 then!, back to my old ****** phone for while.....:mad:
     

Share This Page