iPhone headphones detected but no sound.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rjrivera, Jun 14, 2013.

  1. rjrivera, Jun 14, 2013
    Last edited: Jun 14, 2013

    rjrivera macrumors newbie

    Joined:
    Jun 14, 2013
    #1
    Hi! I was going for a run, but when I clicked on a song, no sound played. I've tried different headphones but nothing. I've tried compressed air, but nothing comes out so I assume it's not dust. When I press the volume buttons the headphones are detected, but no sound plays. Any ideas?

    It's an iPhone 4 by the way.

    Edit: Just tried restoring and it didn't work. I don't think it's a hardware problem. I mean they wouldn't be detected if it was right? It just happened all of the sudden.

    Edit 2: Now they don't even show up. It just says ringer.
     
  2. applejuice99 macrumors member

    Joined:
    Apr 1, 2013
    #2
    Do other sounds play? Or is it just music? If not it sounds a bit like the contacts are corroded in some way, this is sometimes caused by humid conditions or liquid damage, or it could be just the contacts getting old. You could take it to apple and see what they say, and if there is a solution to the problem, and may be repairable.
     
  3. Lylyluvda916 macrumors regular

    Joined:
    Aug 28, 2012
    #3
    maybe your heaphone jack needs to be replaced.
     

Share This Page