iPhone iCal Sync - Events are always listed as wrong date and time

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mashinhead, Feb 8, 2008.

  1. mashinhead macrumors 68020

    Joined:
    Oct 7, 2003
    #1
    Every event I have in iCal shows up at the wrong day or wrong time once synce to the iphone. Anyone else having this issue?
     
  2. cyclingplatypus macrumors 6502a

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #2
    That's a really weird problem. Perhaps you could uncheck all calendars and then sync and then recheck the calendars and sync again.
     
  3. telefono macrumors 6502

    telefono

    Joined:
    Dec 17, 2007
    #3
    Try setting the correct Time & Date on both the iPhone and the PC/Mac, I had this problem when I first got the phone and one of the dates/time wasn't correct.

    Good luck, hope this helps
     
  4. sophiemac2008 macrumors newbie

    Joined:
    Jul 13, 2008
    #4
    I just had the same problem and solved it!

    make sure that in your preferences in iCal that you have the time/zone correctly selected.

    Because i had Australian time zone on my iPhone and American time zone on my mac the times and dates were wrong!

    good luck!
     
  5. jimN macrumors 6502a

    jimN

    Joined:
    Jun 23, 2005
    Location:
    London
    #5
    My birthdays calendar isn't syncing through via mobile me which is a tad frustrating as are the colours which seem inconsistent across the 3 apps (MobileMe, ical and iPhone). Aside from that I do love the fact that the calendar is now mutli-coloured and that my email gets pushed to me - even on my old phone!
     
  6. tico24 macrumors 6502

    tico24

    Joined:
    Jun 17, 2007
    Location:
    Eastleigh, UK
    #6
    If you log in to me.com, under the calendar preferences, there's an option to sync the birthdays calendar.
     
  7. craigw2008 macrumors newbie

    Joined:
    Aug 6, 2008
    #7
    Possible solution

    Hi,

    Just thought I would let you post that I had a similar problem when synching my outlook calendar with my new iphone.
    After having a play in the menus on the iphone I corrected it straight away with no resynching etc.

    By default the iphone settings are wrong for this.

    To change:

    click settings / mail,contacts,calendars then scroll down to calendar and click "Time Zone Support". This will be set to "Cupertino" - (well was for me on 2 phones)

    Set this to "off" and this should then correct the times on all of your calendar items.

    As mentioned this was for synching between outlook on a pc and iphone but may help someone.

    Cheers
     
  8. jamesus macrumors newbie

    Joined:
    Jul 29, 2008
    #8
    I was wondering why when I was on the left coast this past weekend my appointments didn't update correctly. Thanks for the tip!
     
  9. laurose macrumors newbie

    Joined:
    Jun 27, 2009
    #9
    Yay!

    Thank you, craigw2008.

    Your fix worked for me & my new iPhone 3Gs & Mac Book! :)

    I'm wondering, is it possible to set it so that the time zone will always be correct? (For me that would be NYC time.) In case I travel...

    TIA! :)

    ~New to iPhone, not to Mac <3
    bye bye bb...
     
  10. thomas watkins macrumors newbie

    Joined:
    Feb 11, 2010
    #10
    Time conflict iphone and ical

    I was having a problem with my iphone and ical being off by one hour. The mistake that I was making was just going to the time under general on the iphone. The way to make the time be the same is to go under calendar on the iphone and change the time zone to the same under date and time on your mac under the system preferences.

    That fixed my problem.
     
  11. Bishan macrumors newbie

    Joined:
    May 24, 2010
    #11
    Great last tip!

    Thanks Thomas, and MacRumours!

    Your tip helped me. I was still set in Washington DC on the "Calendars time" on iphone, but New Zealand time on the Mac and the "general" time for Iphone.
    Very helpful tip

    cheers
    Bishan :)


    "I was having a problem with my iphone and ical being off by one hour. The mistake that I was making was just going to the time under general on the iphone. The way to make the time be the same is to go under calendar on the iphone and change the time zone to the same under date and time on your mac under the system preferences.

    That fixed my problem."
     
  12. rhenkart macrumors newbie

    Joined:
    May 2, 2011
    #12
    Yes, I have the same problem but just with time. iPad will be 1 hour earlier than Mac iCal.
    :confused:
     
  13. rhenkart macrumors newbie

    Joined:
    May 2, 2011
    #13
    I picked this up on the internet and it solved my time problem on the iPad even though this article was about the iPhone.


    "kamayogi June 6, 2010 at 15:37:50 Pacific
    Windows
    This solution pertains only to the one hour time difference people notice upon syncing to MS outlook.

    In iPhone, there are two areas where you have an option to change your time settings - the device time zone and the calendar time zone - two different things, both will need to be fixed..

    1. When you go to 'settings', then to 'general', you can set up time and date, and also 12-24 hour format. Please note that changing the time here DOES NOT correct the problem, despite iPhone displaying correct date, time and time zone. Many people in this thread have stated that the problem persisted despite them setting appropriate time zone.

    2. When you go to 'settings', then to 'mail, contacts and calendars' row (NOT the 'General' row) - you get an option to change your time zone at the very bottom of all the choices. You will see that wrong time zone is selected here - likely cause of the problem. Correct this choice and the one hour discrepancy between appointments in outlook and iPhone disappears.


    Additional problem solutions - in the solution No. 2, if you set 'Time Zome Support' to 'ON', then all your appointments in the calendar will be displayed in the time zone of your HOME address. In other words, for example, if you are a person in central time zone, your appointments will be displayed ALWAYS in central time zone format - they will NOT change automatically when you travel from central time zone to eastern time zone. On the other hand, if you set the time zone support to 'OFF', then all your outlook appointment display times will change and adjust according to any time zone you travel to - This is often an inconvenience since most of us would like to remember our appointments as they were made in our home time zone, regardless of what time zone we traveled to.

    Please note that the above solution pertains to only display of appoint times in outlook - This solution does NOT relate to the time displayed by iPhone and how that displayed time adjusts when you travel to different time zone away from your home time zone. This second issue is addressed below -

    You can get your iPhone to display the current time in two ways -

    1. Either always show the time in your home time zone, regardless of where you are (i.e., a person from Texas central time zone can set up to see the time always in central time, even if he/she travels to another time zone). This display setup is good for people who always think of time in their home time zone and then do mental conversions to reach at the local time zone time.

    2. On the other hand, you can get iPhone to do this for you and change displayed clock time automatically to the local time zone that you have traveled to, away from your home time zone. Please note that enabling this capability in iPhone has no bearing on how the appointments are displayed in MS outlook.

    Go to 'Settings'. Go to 'General' tab. then click on 'date and time'. Pick the 'set automatically' option to 'ON'. Now, the iPhone will automatically adjust displayed time to show the current time in which ever time zone you travel to.

    If you set the 'set automatically' option to 'OFF', then you can select your home time zone. Then, the iPhone will always display time in your home city time zone and will NOT change even if you travel to a different time zone.

    So, in summary, there are two places you need to adjust the time zones in iPhone - to do two separate tasks, first task of displaying appointments always in your home time zone upon syncing with outlook thereby avoiding the one hour skip; Second task of getting iPhone to display either your home time zone clock, or getting it to adjust current time to reflect the time in new time zone you travel to.

    Hope this helps. "
     
  14. bebopple macrumors newbie

    Joined:
    Sep 6, 2011
  15. Elle22 macrumors newbie

    Joined:
    Sep 13, 2011
    #15
    fix not working

    Is there anyone who has found that none of these fixes work? My calendar on my iPhone 4 is consistently 2 hours ahead of my iCal. I have tried all of the above fixes, including various combinations of each (i.e. leaving time zone support on and off; turning 'set manually' both on and off).

    Any other thoughts?
     

Share This Page