iPhone <-->iCal Sync = Wrong Times

Discussion in 'iPhone Tips, Help and Troubleshooting' started by DSchwartz88, Sep 21, 2007.

  1. DSchwartz88 macrumors 6502

    May 18, 2006
    So out of no where after i restored my iPhone the other day when i sync my calendar with iCal the time on the iPhone are all wrong. It says i have appointments at 8am when they arent till 4pm. This happen to anyone? Anyway to fix it? Anyone know why this is happening all of a sudden?

  2. chopper dave macrumors regular

    Jul 23, 2007
    You probably have the time zone set wrong on either your computer or your iPhone, and probably has something to do with "time zone support" in iCal advanced options.
  3. sJv macrumors regular

    Jul 11, 2007
    Sierra Foothills, CA
    I have an even weirder problem that has been there since 1.0.0. All my Monday appointments are off by one hour, but the rest of the week are fine. All the appointments in iCal, including monday, are correct. Maybe my iPhone has a case of the Mondays? :)

  4. alanan43 macrumors newbie

    Jun 12, 2009
    iPhone <-->iCal Sync = Wrong Times

    I have the same problem -- times on iPhone calendar 6 hours ahead of "real" (computer) time. Times zones both set. Help! going nuts!
  5. laurose macrumors newbie

    Jun 27, 2009
  6. sam011989 macrumors regular

    Jun 17, 2009
    Tucson, AZ
    The timezone for ICal and the calendar app on the iPhone may be right, but make sure the event itself in iCal is set to the correct time zone. Watch your time zones, there are several places they can be changed
  7. thomas watkins macrumors newbie

    Feb 11, 2010
    Time conflict iphone & iCal

    I was having a problem with my iphone and ical being off by one hour. The mistake that I was making was just going to the time under general on the iphone. The way to make the time be the same is to go under calendar on the iphone and change the time zone to the same under date and time on your mac under the system preferences.

    That fixed my problem.
  8. VulchR macrumors 68020


    Jun 8, 2009
    Don't they ban users from this forum for using phrases like that?
  9. sarat318 macrumors newbie

    Aug 21, 2010
    Persistent problem

    I bought my iPhone and Macbook specifically because my lifestyle has reached a pace where a paper calendar just doesn't do it for me. I really, really need them to sync but for some reason my iPhone 4 INSISTS on setting my appointments back three hours! I have tried all of the suggested techniques here. I have reset my computer and my phone time zones (in both general and in calendar settings for the phone) to New York time and then tried to sync. I've tried setting both to "automatic" time zones. I have tried every combination of changing one and then the other, resyncing in between every thing. I have turned off my phone and my computer and restarted. I can't change the events manually because as soon as I plug my phone in again, they sync back to the old times! What can I do? I would be forever indebted to the kind soul who can help me. :)
  10. actionsalmon macrumors newbie

    Sep 8, 2010
    Yeah, my iPhone 4 is doing exactly the same thing. It's changed all my iCal times by 3 hours. I did just move across country, but as far as i can tell, all my time zones are correct now and it's still not working. Please help!
  11. actionsalmon macrumors newbie

    Sep 8, 2010
    actually, in the end, i hadn't changed all the timezones - the key was the calendar settings on my iphone. i suck. :(
  12. Batracho macrumors newbie

    Jul 18, 2010
    Had the problem, telephone calendar settings on iphone solved it.
  13. drcjc macrumors newbie


    Oct 22, 2010
    ipod touch similar problem

    I am having the same sort of problem. I have checked the time under system prefs on my iMAC (leopard) and on my ipod touch under settings>general> date time. They read the same but when I sync my calendars from my MAC to the touch the items are 9 hours later on the correct date. Is there some other place on the touch to change time settings?
  14. gigapocket1 macrumors 65816

    Mar 15, 2009
    I had the same problem.. All u have to do is go to settings - mail,contacts, calendars.. You will see at the bottom it says time zone support.. Turn that off.. That should fix it
  15. drcjc macrumors newbie


    Oct 22, 2010

    I think this did it! I never even saw that setting option before. Thanks so much.
  16. jer16 macrumors newbie


    Nov 12, 2008
    Brilliant!! Thank you.

Share This Page