iPhone iMessaging Windows Phone

Discussion in 'iPhone' started by johnomac13, May 20, 2013.

  1. johnomac13 macrumors newbie

    Joined:
    May 20, 2013
    #1
    My brother (who has NEVER owned an Apple product) just bought a new Windows 8 phone. This is the first smart phone he has owned. This is also a brand new phone number. Whenever I try to send him a text message, my iPhone attempts to sent it as an iMessage. In order for my brother to receive the messages, I have to either touch the message and send as Text (which doesn't always work as the message sends too fast) or disable iMessage which I do not want to do as all my other contacts use iMessage. This has been going on for two months now. I have went to an Apple store and spoke to two different "geniuses". Both of them did not know what to do and have never heard of this issue. ALSO, this is not only my iPhone 4. The same thing happens to my wifes iPhone 4S and my coworkers iPhone 5. It only seems to be happening to my brother windows 8 phone.

    Any help would be nice.

    Thank you.

    John
     
  2. paulbennett95 macrumors 6502a

    paulbennett95

    Joined:
    Aug 30, 2012
    Location:
    Long Island, NY
    #2
    Is his number in Contacts listed as Mobile or iPhone? If its listed as Mobile, try setting it as a Home number.

    No other ideas than that, sorry.
     
  3. johnomac13 thread starter macrumors newbie

    Joined:
    May 20, 2013
    #3
    Thanks for the suggestion. I did try that and sadly it did not work.
     
  4. RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #4
    What version is your iOS? When IMessage was first introduced, there were problems when a number which had previously been used with an iPhone changed to a different model.

    It is strange, however, that you say your brother has never owned an Apple product.

    If the message sends as an iMessage, do you get a 'Delivered' underneath the message. If that's the case it's being delivered somewhere...

    Another suggestion would be to put his number in your contacts in the international format. If you're in the NANP area, it just requires a + in front of the 1.

    EDIT: just had a thought. Someone somewhere has set up iMessage on an iOS device (maybe an ipad or iPod touch) using your brother's phone number. Maybe this person used to have this number, or they typed it in by mistake.

    Like I said above, if it says 'Delivered' it's appearing somewhere. Maybe you could send a text explaining the situation. Or maybe you could try FaceTime?
     
  5. johnomac13 thread starter macrumors newbie

    Joined:
    May 20, 2013
    #5
    I find it very strang as well.

    I am using the most up-to-date version of iOS there is for the iPhone 4. But like I said, it can't be My iPhone as it is also happening to 2 different iPhones, an iPhone 4s as well as the 5.

    Yes, it does in fact give me a 'delivered' message as well as a 'Read' message.

    I just sent a message explaining regarding what is happening to whoever is receiving my messages. and for them to email me. I'll see what happens from there.
     
  6. BruiserB, May 20, 2013
    Last edited: May 20, 2013

    BruiserB macrumors 65816

    Joined:
    Aug 9, 2008
    #6
    You say it's a new number for your brother, but it doesn't mean that that number didn't at one time belong to someone who had an iPhone and had it registered for iMessage. As someone else said, they may have somehow kept the number active on their AppleID by having it tied to their other iDevices.

    This will be a pain for your brother as this will happen to anyone with an iPhone who tries to text him. Seems like Apple Support should have some way to deactivate the number for iMessage.

    This is probably the solution....problem is that the iMessage number isn't associated with your brother's AppleID, so he would have to get the previous owner of the number to disable it...so if the person answers your text, maybe they will help.

    http://www.lifehacker.com.au/2012/01/fix-the-imessage-iphone-to-android-bug/

    Maybe your brother could contact his carrier and just ask for a new number to be assigned. Since he hasn't had this one long, maybe it wouldn't be an issue to change it.
     
  7. johnomac13 thread starter macrumors newbie

    Joined:
    May 20, 2013
    #7
    That makes sense. I will have him call his carrier and see if they can help him out.

    Thanks for the help!
     
  8. BruiserB macrumors 65816

    Joined:
    Aug 9, 2008
    #8
    Or maybe you could put his sim chip into your iPhone and then it will activate his number to your AppleID instead of the person's who has it now. Then you could go delete the number off your profile with the method in the link above.
     
  9. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #9
    Apple really needs to put something in place to solve this problem.

    The way that iMessage overrides an existing system is pretty dodgy (i.e. by automatically replacing SMS - with no option to disable that on a case-by-case basis). To then have no way for the legitimate user of a number to disable iMessage without having the device that it was activated on is just broken.

    Other companies would probably have used some sort of web interface to solve this problem, but that doesn't really fit in with the Apple "everything should be an App" philosophy.

    Something like:

    • Go to support.apple.com/imessage
    • Enter your phone number
    • Apple sends a verification code to check that it's really your number
    • Then a single option to remove that number from all devices for iMessage
     
  10. RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #10
    Did you ever get this problem sorted?
     

Share This Page