iPhone insists on 2 inboxes for my 1 Gmail account

Discussion in 'iPhone Tips, Help and Troubleshooting' started by vialli25, Jun 24, 2009.

  1. vialli25 macrumors newbie

    Joined:
    Jun 9, 2009
    #1
    Hi

    I got the new iPhone 3GS about 3 days ago. The first iPhone I've owned.

    I have a problem with the mail application.

    On my mac, I retrieve my Gmail via POP using the Mail application. I told my iPhone to sync with my macbook so that I would be able to download my gmail on my iphone as well. This works fine.

    HOWEVER...

    On the mail app on my iPhone there are 2 inboxes, the normal Mail Inbox, and 'All Mail' under a Gmail folder.

    When I receive new email, they go into my inbox, but also into the gmail 'All Mail' folder as well.

    How can I stop my iPhone from using this gmail folder? I never set it up, and would rather just all my emails be in my inbox only.

    The mail from my Inbox also disappears once I've read it and it seems everything is archived in the Gmail 'All Mail' folder. It's annoying because I have to go and read the emails in my Inbox folder, but then I have to go and read the same emails in the 'All Mail' folder for them to stop being classed as new emails in the 'All Mail' folder.

    Any help would be very much appreciated!!!
     
  2. vialli25 thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #2
    I just changed from POP to IMAP in case this was the problem but it's not. I sill have Inbox and 'All Mail' on my iPhone. Strange. I would prefer to have one or the other, not both.
     
  3. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #3
    Wirelessly posted (iPod touch 32GB: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

    It's just the way gmail works - all mail is effectively a search folder which shows your inbox items and any archived mail. You can't disable it.
     
  4. vialli25 thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #4
    So it's like this on everyone's iPhone that uses Gmail? It's a pain in the arse, it doesn't do it on my mail application on my mac.

    Does anyone know why messages that I've read on my Mail inbox disappear?
     
  5. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #5
    iphone inbox

    This is the way it is suppossed to be on gmail on the iphone.

    the ALL MAIL is the imap tag that is ALL MAIL, and showing in your sub folders essentially, since that is the way they get resolved on the iphone.

    If you have any tags or categories setup on your gmail, like travel or receipts or something, you will also have those "folders" listed.

    If you don't go IN to them, they won't have anything IN them, since the results of them are not downloaded from the server unless you make a direct query.

    I don't thin they use any space, unless you go into them and DL to them.
     
  6. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #6
    I just ignore the "ALL MAIL" folder -- I just never open it. And I have no idea why read messages are disappearing from your inbox, because my messages stay in the inbox until I move or delete them. Maybe you have something set up on Gmail that automatically archives mail when you read them?
     
  7. vialli25 thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #7
    Hmm...

    It just bugs me!! At the moment, the 'All Mail' folder is telling me I have an unread message in it which I don't.

    And I just sent a message from my iPhone. Instead of it going into my Sent Mail folder, it has created a new folder called 'Sent Messages' which is now viewable on gmail.com and on my iphone.

    I know it sounds strange, but I like to keep my emails locally, rather than synchronising with the gmail server. This works fine through POP using my Mail App on my mac, but the iPhone insists on synchronising with gmail.com even if I use POP.
     
  8. vialli25 thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #8
    I've done it!

    I now have just an Inbox and Sent folder on my iPhone, and Inbox and Sent folder on my mac. It's a lot less complicated this way.

    For anybody who wants this set up follow these steps.

    1. Delete all mail accounts on your iPhone and Mac.

    2. Stop your mac from synchronising any mail accounts with your iPhone (untick the box in iTunes)

    3. Manually set up your mail account on both the iPhone and Mac using POP. You can do this on your iPhone by selecting 'Other' when it asks you to set up a mail account. Be sure to select the big POP button on your iPhone otherwise it automatically uses IMAP and messes the whole thing up.

    4. Once you have manually set up your gmail account on both your mac and iPhone check to make sure they work independently of each other. You might find that if the iPhone downloads an email, then it will not get picked up by your mac, assuming you want local copies on both systems.

    5. Go back into iTunes and retick the synchronise selected Mail accounts. Synchronise your Mac and iPhone and now it should work. You should be able to download emails on your iPhone with just an Inbox and Sent folder without getting all the extras from Gmail. When you log onto your mac, it will also download the emails your iPhone has so you have every email locally stored on both your Mac and iPhone without the confusion of ALL MAIL and the iPhone creating additional Sent folders!!!
     

Share This Page