iPhone iOS 4.2.1 car stereo problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ELScorcho9, Nov 22, 2010.

  1. ELScorcho9 macrumors member

    Joined:
    Sep 25, 2009
    #1
    So I upgraded my iPhone 4 to iOS 4.2.1 this afternoon like everyone else and now I'm having issues with it playing on my car stereo. I was having static issues when it played back previously and this update was supposed to fix it. Now when I connect it, my car stereo reads "iPod Error" and the iPhone says "iPhone not compatible with this device." So before there was static and now it doesn't even play.


    Anyone else have these issues? Is there a fix and I'm just stupid?
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    What car stereo do you have? I have an Alpine that I use an iPod Classic with. Works great for me. I just load it up with tons of tunes and leave it in the glove box. I only take it out to add more tunes or playlists. This way I don't have to plug my 3GS in all the time.

    Also, check with your stereo manufacturer, maybe they have or will have a firmware update for it to be compatible with 4.2.
     
  3. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #3
    I was having a similar issue, with my new iTrip Auto with my new iPhone 4. When I try to stream audio, via Safari, it works for a few minutes, then the iTrip stops broadcasting. Yet if the source is the iPod app, it works just fine. I'm hoping it is either related to our cold weather, or the iPhone being confused and thinking it was connected to a TV (as that is what it showed instead of the standard QT logo when streaming). Otherwise, I may need to find another broadcasting solution when streaming.

    TEG
     
  4. martijnroosen macrumors newbie

    Joined:
    Nov 23, 2010
    #4
    +1 in combination with a Alpine iDAx001 carstereo. I'm not amused...
     
  5. ELScorcho9 thread starter macrumors member

    Joined:
    Sep 25, 2009
    #5
    Yup. That's the exact model I have. Not too thrilled about it. I was happy when I heard there was a fix for the static problem, but this is just stupid. Glad I'm not the only one, I guess...

    I used to have an iPod I kept in the glovebox, just like you said, but unfortunately it was stolen a year ago. I've never had an issue with the iPhone not working. There's been static off and on, but it still played.
     
  6. RobNYC macrumors 6502

    Joined:
    May 28, 2008
    Location:
    New York, NY
    #6
    For those of you having problems, are you directly connecting your iphone to your radio though the pin connector or through blue-tooth?
     
  7. Klaytonk macrumors newbie

    Joined:
    Nov 23, 2010
    #7
    Major iPhone 4 car conneciton issues!

    I am having major issues as well. I connect through the Pin Adapter to my 2010 Genisis Coupe. Have never had any problem playing my iPod through the iPod connector but upon updating to 4.2.1 my iPod just keeps connecting and disconnecting. Its annoying, I can't plug it in because it just goes in a loop and never plays or lets me select any other setting, radio, XM, etc.
     
  8. b0blndsy macrumors 6502

    Joined:
    Nov 9, 2010
    Location:
    Illinois
    #8
  9. RobNYC macrumors 6502

    Joined:
    May 28, 2008
    Location:
    New York, NY
    #9
    Uh oh. Okay, well I never had any trouble with the last couple of updates plugging it into my car. It always gave me the warning about it not being compatible but it always played no problem. I guess I'll find out tonight whether it's going to work ok or not.
     
  10. ELScorcho9 thread starter macrumors member

    Joined:
    Sep 25, 2009
    #10
    That thread started when iOS 4.0 first came out. My iPhone 4 worked with iOS 4.0 and 4.1, and now doesn't with 4.2.1. I'll call the manufacturer just to see what they say, but this is Apple's screw up in my opinion.


    I connect mine through the pin connector.
     
  11. Klaytonk macrumors newbie

    Joined:
    Nov 23, 2010
    #11
    Contact manufacturer? Are you kidding?

    Why would I contact my Manufacturer for an update? Its worked fine for over a year, through multiple updates. This is Apples mistake obviously, its not even new hardware, just a software screwup on their part.
     
  12. maceleven macrumors 6502

    #12
    Error Alpine iDA-X305S

    im getting the same thing on my Alpine iDA-X305S Succcccks !!!
     
  13. krugerjl macrumors newbie

    Joined:
    Jul 23, 2010
    #13
    Mine is fine

    On the previous IOS 4 versions, when i used to plug it in, my device hanged up, Ipod crashes.

    I downgraded to 3.1.3 for this only.

    Yesterday i upgraded to 4.2.1 hoping that it will be resolved, and yes, mine is working fine.

    I am using Iphone 3G
    With the AUX cable plugging in at the connector on the Iphone (Where it is used to dock)

    I am glad, hope you guys gets it working!
     
  14. maceleven, Nov 24, 2010
    Last edited: Nov 24, 2010

    maceleven macrumors 6502

    #14
    I am making an appointment at Apple genius bar and gonna get my iPhone 4 Swapped out forget that !

    my Alpine IDA X305S works fine but my Alpine IDA X001 is working with the new update .
     
  15. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #15
    i dont mean to thread jack at all, but i have a small issue with my aftermarket headunit. i got the pioneer 3200ub and to my surprise it plays pandora and navigon instructions through usb to the head unit.. (thought it needed aux, but dont)

    first of all, i am on 4.1 still, but while pandora is playing through the headunit, i am unable to control the skips through double tapping home button. it just shows the ipod icon.. so the only way to skip to the next song is to use the pandora app.. is there a fix for this? thanks!
     
  16. maceleven macrumors 6502

    #16
    I Downgraded back to 4.1

    After a long wait at the Apple store they couldnt do a damn thing, but the genius told me to Downgrade at home (20 minute process) now everything is back to normal. Exhausted !!!!!
     
  17. soLoredd macrumors 6502a

    Joined:
    Mar 12, 2007
    Location:
    California
    #17
    What a pain!

    While I enjoyed the original iPhone working in my SUV with a USASpec iPod adapter, the subsequent models don't work with it anymore. I've just accepted it and like one of the above posters, keep an 80GB iPod Classic in there with my entire music library. That way, no matter what Apple does with the iPhone (changing the charging connector, like they did with the 3GS, etc) I will always have my music and it will always work. I debated for a month on upgrading the USASpec to a new model but in the end it just isn't worth it to me.

    It would be cool to have an AirPlay-ready car system in the future though :cool:
     
  18. bwild3 macrumors newbie

    Joined:
    Nov 26, 2010
    #18
    I called an talked to Apple today about the iPod Error with the Alpine IDA. They told me it had nothing to do with iOS 4.2 and that I should contact Alpine about a firmware update. Apple support told me it wasn't their place to make sure their products and updates worked with non-apple products. Not surprised that Apple is denying that they caused the problem.
     
  19. gcbspender macrumors newbie

    Joined:
    Nov 29, 2010
    #19
    Same problem here with same setup, iphone 4, ios 4.2.1, Alpine x001. This was broken by the update and should be fixed with an update. I am just guessing but Alpine will not have a firmware fix for this, they have never supplied firmware updates, this is why they keep coming out with new models that have better functionality than the x001. We are screwed until Apple fixes this.
     
  20. Nebi macrumors newbie

    Joined:
    Dec 10, 2010
    #20
    Sony XAV 60 problems

    I have an iPhone 4, with 4.2.1 firmware, I used to have a problem when I connected it with my Sony XAV60 back when it was 4.1, but now with the new update it plays just fine. The new problem is, I can't increase or decrease the volume on my stereo when connected, it works just fine when I connect other iPods. But with my phone it just doesn't. I have to go back to the radio increase the volume, then go back to the USB to listen. Does anyone have this problem... Pls help!!
    I connect it using Via USB
     
  21. alba812 macrumors newbie

    Joined:
    Jan 7, 2011
    #21
    I'm having the same exact issue. I recently updated my itouch and now it won't play in my car.
     
  22. jthomp macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    the 717
    #22
    Count me in as well! Ida-x001 worked on ALL but 4.2.1. All I get is some "iPod error" message. Never happened before. Pretty crappy if you ask me...
     
  23. jthomp macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    the 717
    #23
    FYI - Updated to 4.3.1 the other day. Jailbroke using redsn0w. Took the phone out to the car and hooked it up to the stereo, and it now works again...
     

Share This Page