iPhone/iPad iMessages

Savage

macrumors 6502
Original poster
Mar 12, 2008
285
2
SoCal
Got my girlfriend the new iPad yesterday. We both have iPhones. We could use some help setting up the messaging system.

How it is now: I can send an iMessage to her iPad with my phone under her main contact in my phone, but in my Messages app, it's in a separate conversation from the normal iPhone to iPhone conversation we have going (I have her iPad's messaging email in her contact profile). So if she were listed in my phone as "Girlfriend", it would say "Girlfriend" twice in my messages app, with two different conversations.

Goal: I want to have anything I send to/she sends from the iPad, to be combined right into the original iPhone to iPhone conversation in my phone. Additionally, it would be nice if whatever she receives from me would go to both of her devices.

Kind of confusing but I have a feeling it's possible, it just don't know how to do it. Thanks in advance.
 

BigDukeSix

macrumors 6502a
Sep 22, 2010
718
0
34.6700N 118.1590W
I don't think you can combine the two.
If you send from iPhone to iPad, that is once conversation since it is going to an email address.
If you go from iPhone to iPhone, that is another conversation since it is going to a phone number.
At least that is how it is working for me to my wife's iPhone and iPad.
 

MasterHowl

macrumors 65816
Oct 3, 2010
1,017
17
North of England
I had this problem!

Right, go into your iPhone settings, Messages, and "Receive At". Make sure your email address is entered.

Then get your girlfriend to close all your conversations on her iPhone (sorry if she's the type that likes to keep all messages!) and you should be good to go.

Took me a while to work out too...
 

Arelunde

macrumors 6502a
Jul 6, 2011
980
28
CA Central Coast
On your iPhone, make sure you have your phone number AND your email address as eligible for iMessages in settings. On your iPad, enable email.

I found once I sent an iMessage to another iDevice via iPad (wifi only), it showed up on both my devices from that point on. If I sent it first from my iPhone, it only showed up on my iPhone. Weird, but true.
 
Last edited:

Sylon

macrumors 68020
Feb 26, 2012
2,031
80
Michigan/Ohio, USA
My friends have this issue when they are talking to me on my MBP/iPad or on my phone. They have 2 conversations for me.

The big annoying thing for me is having to wait for my iPad or MBP to relive the long conversations I had on my iPhone. Sitting there waiting for all the old messages to load gets irritating.

Apple had good intentions with the creation of iMessage, but the execution was downright awful.
 

jaded-mandarin

macrumors regular
Jan 1, 2008
179
109
UK
I just changed my settings as advised on here, and when I write an iMessage on my iPad it shows up on my phone as soon as it's sent. However when I received a reply, it came through to my phone only...
 

Savage

macrumors 6502
Original poster
Mar 12, 2008
285
2
SoCal
I had this problem!

Right, go into your iPhone settings, Messages, and "Receive At". Make sure your email address is entered.

Then get your girlfriend to close all your conversations on her iPhone (sorry if she's the type that likes to keep all messages!) and you should be good to go.

Took me a while to work out too...
I got it so that if I iMessage my girlfriend to her email, it will go to both her phone and iPad. However, I am definitely not about to clear our messaging conversation out of my phone. There has to be another way I can have her iPad/iPhone listed as one conversation in my messages. :mad: