iphone is bricked and i need help//urgent!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by johndoe2, Apr 2, 2012.

  1. johndoe2 macrumors newbie

    Joined:
    Apr 2, 2012
    #1
    Hello everyone, I am indeed a new member here and I hope someone out there will be able to help me.

    Briefly here is my situation:

    I have an Iphone 4 that was on IOS 4.0.1 and it's jailed broken and unlocked on T-mobile. I decided to do all of the update on Cydia and was successful. Then I happened to scroll around the other mods in Cydia such as the tweaks and stuff. I downloaded a bunch and downloaded one in particular that said that Winterboard needed to be restarted, I pressed okay then bam. I knew it was bricked right when the phone took forever to restart. Sooo now my phone is stuck on the apple logo and I do not want to lose everything on my phone including all of my notes/music/contacts/videos/calendar/photos and other valuable memories and apps that I have. My question is, can someone help me or shoot me ideas on how to unbrick my phone without restoring it? I've had this phone for more then a year now and it contains a lot of things I do not want to lose. If anyone can help please and thanks!

    P.S. I'm also a Mac user if that helps in any way..
     
  2. confucious macrumors 6502

    Joined:
    Nov 19, 2010
    Location:
    Woking, UK
  3. EngageWithRage macrumors 6502

    EngageWithRage

    Joined:
    Jan 30, 2012
    Location:
    Your girlfriend's house
    #3
    If you have installed something and need to uninstall it without losing your jailbreak/can't get into your phone to do a traditional uninstall, you can always do the following:

    Download/Install iFunbox http://ifunboxmac.com/

    Plug in your phone via USB and open up the SSH Terminal Window

    You need to know the package name that you installed "com.XXX.xXX" and run the following command:

    apt-get --purge remove (source name)
    (If that does not work you can try "dpkg -r nameofpkg")

    Then type in "reboot" in the command line and hit ENTER to reboot the phone
     
  4. johndoe2 thread starter macrumors newbie

    Joined:
    Apr 2, 2012
    #4
    I tried to reinstall redsn0w and this message came up:

    Missing Keys.plist data for this build:

    Device: iPhone4
    ECID: 43823111*****
    Build: iPhone3,1_4.0.1_8A306
     
  5. bandofbrothers macrumors 601

    bandofbrothers

    Joined:
    Oct 14, 2007
    Location:
    Uk
    #5
    Some times it hangs and goes into safe mode.

    Press the powerbutton and then the home button till it resets.
     
  6. DGreenMan macrumors newbie

    Joined:
    Aug 5, 2011
    #6
    ive got this same issue with same error same firmware only diff is obviously the ecid

    did you manage to fix your phone without loosing everything

    ive been at this for the past 24 hour now and its realy getting to me now

    any help would be much appreciated johndoe
     
  7. someshmishra macrumors newbie

    Joined:
    May 10, 2012
    #7

    if it is not in warranty and if u have small skill for opening screws then just open two screws and open the back cover and then remove the battery screw there and then remove battery cable gently and then plug it back it will boot up in few seconds
    DO IT SlOWLY AND SMOOTHLY OR ELSI IT CAN SHORT YOU IPHONE'S MB
     

Share This Page