iPhone Issue: Skipping Songs

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Possédé, Mar 5, 2008.

  1. Possédé macrumors member

    Joined:
    Feb 5, 2008
    Location:
    Scotland, United Kingdom
    #1
    Hello,

    Well, I recently purchased the 16GB iPhone, and so far I am really pleased with it. Though, there is one thing that has been nagging me... Sometimes when I listen to music on my iPhone the song will randomly skip to the next track. This can be within 10 seconds of the song beginning, but usually occurs half-way through the song. My songs are all encoded at 320kbps AAC, and they aren't downloaded or whatnot. I originally thought it may have to do with available memory, and have tried playing music upon switching on my iPhone - but they still skip. Has anyone else had this issue? What do people suggest I do to resolve this issue?

    Thank you.
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Sounds like an error in the file. Reencode them and see if it still happens. Also, try 256kbps, as I think 320kbps is close to the maximum threshold.

    TEG
     
  3. Possédé thread starter macrumors member

    Joined:
    Feb 5, 2008
    Location:
    Scotland, United Kingdom
    #3
    Thank you for your reply.

    Would I need to re-encode my 1500 song library all again? I never knew the iPhone had a AAC 320kbps threshold. Seems strange, my previous iPod Nano could handle all the same files perfectly (And the iPod I had before that). I will give restoring the iPhone a try, and see if that works.
     
  4. swoosh0217 macrumors 6502a

    swoosh0217

    Joined:
    Nov 20, 2007
    Location:
    NW
    #4
    Right click on a song you have selected. Go to "Info" and then "Options". Now look at the start and end time of the song. Does it display seconds or minutes?
     
  5. Possédé thread starter macrumors member

    Joined:
    Feb 5, 2008
    Location:
    Scotland, United Kingdom
    #5
    swoosh - the song(s) are displayed in seconds.

    Well, I decided to restore the phone and put my music back on it, but to no avail. HOWEVER, after much desperation, I decided to use the dock (instead of just the wire) and use a USB input from the back of my computer, do a restore, and put my songs back on and so far the songs haven't skipped. Weird. So I hope that is the problem solved for good. :) Thanks for the input.
     
  6. swoosh0217 macrumors 6502a

    swoosh0217

    Joined:
    Nov 20, 2007
    Location:
    NW
    #6

    I'm glad that solve your problem. Have you use your songs as ringtones and did some modification as far as the start and end time? That was your problem. Songs are normally about 3 to 4 minutes long and this is what makes you think your songs skips because it only plays up to a certain seconds where it suppose to play for certain minutes.

    Next time before you do a restore, if it gives you the same problem; try fixing the time start and end time to its original time setting.
     

Share This Page