iPhone jailbreak cydia keeps on crashing, help please

Discussion in 'Jailbreaks and iOS Hacks' started by tctuner7, Aug 5, 2009.

  1. tctuner7 macrumors member

    Joined:
    Aug 5, 2009
    #1
    Alright here is my issue I have an iPhone 3G with the 3.0 software on it and downloaded redsn0w jailbreak to it. Everything has been working just fine for the past couple of weeks, then cydia wouldn't load or it would say "Loading Data" and then crash to the springboard. I didn't have SSH added to the phone so i could really to get uninstalling cydia to re-installing it via SSH, so what I did was restore my phone but the problem is that the new software 3.0.1 is out and restored my phone that. I read on the dev team blog how to get around or their "trick" to get the jailbreak to work with 3.0.1. So I did all the steps and figured that it would all work again, but cydia is still crashing.I don't really know what to do here? I have been reading all the different post about cydia failing here and there and have tried what i could without SSH, and I'm still stumped.

    Any help is appreciated.

    Also before i restored I had poof! on my phone and some of the applications are still hidden after the restore (some of the apps are like stocks and voice memos, the stuff that normally comes with the phone) how do i get them back? If i can't no biggy never really used them.

    I hope cydia is just having issues, or updates are going on and cydia is down just for that.
     
  2. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #2
    during this time did you try to load anything new, any updates?

    oh yeah what trick are you talking about. I did the 3.0.1 update last night on my 3G and didn't ahve to perform an trickery
     
  3. tctuner7 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #3
    During this time I couldn't download anything in cydia. I could get into it, it would crash.

    and from the dev team website this is what they said:

    "You can re-use redsn0w v0.8 we released a few weeks ago to jailbreak today’s 3.0.1 update. Just let iTunes update or restore you to official 3.0.1 then run redsn0w. The only “trick” is that when redsn0w asks you to identify the IPSW used, point it at the 3.0 IPSW instead of the 3.0.1 one. After the jailbreak, reinstall ultrasn0w 0.9 if you need the unlock."
     
  4. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #4
  5. tctuner7 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #5
    thanks for the help but since i have a mac and can't get to it via ssh, im and restoring the phone and putting the new redsn0w 0.8 on.

    Thanks again.
     
  6. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #6
    check this program out. I use it and it makes SSH'ing a breeze.

    http://www.digidna.net/diskaid/

    I think its a must have especially if you are themeing and so on.
     
  7. tctuner7 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #7
    Thanks man Ill look into it. Im just waiting for the restore now......... epic fail
     
  8. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
  9. tctuner7 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #9
    I figured that it was just a matter of time. I deal with lots of pc stuff like i have a car computer and its constatly troubleshooting and ish. I just hate waiting lol.
     
  10. veejay92 macrumors newbie

    Joined:
    Aug 9, 2009
    #10
    My cydia is also crashing

    I am having the same issues as the quote below. I recently jailbroke using 3.0 software and all of a sudden my cydia started crashing. I have recently read posts that said you can use SSH and delete certain files and the problem will clear up. Well I have no experience using SSH and am completely confused about doing this. I really wish I could use Cydia again and would welcome anyone who can walk me through using SSH.


     
  11. tctuner7 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #11
    Alright well my phone is working fine now and these are all the steps in which I took to get it to work.

    1. I had to restore my phone to brand new like I just bought it.
    2. Then after all of that I re-installed redsn0w 0.8 using the 3.0 ipsw, with the update of 3.0.1 on the phone.
    3. Then cydia is working fine again.

    *make sure to back up contacts, photos, and etc. WITHOUT USING THE ITUNES BACKUP. If you use the itunes back up ALL YOUR PROBLEMS WILL RETURN EVEN AFTER THE RESTORE AND RE-INSTALL.

    Hope this helps. if you need more detail let me know
     
  12. mdwsta4 macrumors 65816

    Joined:
    Jul 23, 2007
    #12
    weird, Cydia just started crashing for me this weekend. i've had my 3GS jailbroken since it was released and haven't had an problems up until now. only thing i can think of is an sbsetting theme i installed.

    followed this tutorial and it works fine.
     
  13. macfan09 macrumors member

    Joined:
    Dec 4, 2008
    #13
    Read this when "all else fails" and BEFORE you restore

    I, like many of those on this thread, had problems a few days ago with Cydia crashing to Springboard upon entry. I scoured this board for possible solutions and tried ALL of the SSH tricks (even BigBoss' solution posted on his website) and still Cydia kept crashing.

    It then dawned on me that I had downloaded some of the tv/movie streaming/download apps from Cydia and that in fact I had downloaded a couple of big files on my phone which had started triggering the 'you're running out of space' messages on my phone (which I of course had ignored.)

    After downloading these files to my computer via SSH, I then deleted them from my phone to open up room and voilá Cydia was back to working. No need to restore or even re-jb. I'm sure I'm not the only one on this board who 'maxes out' the space on their phone.

    If your phone is not full to capacity, of course, this fix may not work for you. But if I can save somebody the hassle of restoring their phone and the tedious process that comes with that, then I'll be glad to have been of help.
     
  14. darkster13 macrumors newbie

    Joined:
    Aug 15, 2009
    #14
    how would you go about restoring your contacts and information without using iTunes. Will selecting "new phone" screw up your existing at&t plan?
     

Share This Page