iPhone keeps asking for Exchange password

Discussion in 'iPhone' started by andybno1, Jun 1, 2011.

  1. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #1
    so I got gmail setup via exchange, I used the correct password as I never get asked when I am in the mail app but for some reason outside the mail app I keep geting a popup saying my password is incorrect and to re-enter it.

    I enter the same password the popup goes away but later on I will get the same popup again..... sometimes if left for long period I will have about 4 or 5 popups to deal with asking for my password.

    Anyone else get this?
     
  2. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #2
    I'd try going to the following page:

    https://www.google.com/accounts/DisplayUnlockCaptcha

    Sometimes Google randomly locks Gmail accounts from external access (anything other than through their web site) as a security precaution if it detects any activity it thinks is suspicious (it could just be you logging in a certain number of times).

    While you say that everything works fine when the App is open, there could be an issue that's happening periodically resulting in the error.

    The form I linked to above will validate your account details and ensure that this isn't the cause.

    I understand that what I'm asking you to do might sound a bit like a scam, so I'll also give you the instructions on how to do this from the Gmail site on your computer:

    1) Sign in on Google.com to the Gmail service.
    2) Click the Cog icon in the top right hand corner of the page and then "Mail Help"
    3) Search for "Captcha" in the "What can we help you with?" search box
    4) Follow the instructions and link provided (the top result).
     
  3. andybno1 thread starter macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #3
    cheers for the help Daveoc64 I hope the captcha helps sort this issue :)
     
  4. tantanz macrumors newbie

    Joined:
    Oct 13, 2009
    #4
    I had this same problem with my company's exchange account. I solved this by entering domainname\username and password instead of only username and password. Not sure in your gmail case what should be used.
     
  5. andybno1, Jun 2, 2011
    Last edited: Jun 2, 2011

    andybno1 thread starter macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #5
  6. actively.seekng macrumors newbie

    actively.seekng

    Joined:
    Feb 1, 2012
    #6
    HELP NEEDED: Gmail Still prompts for password

    I have an iphone 4s with 5.0.1.

    I just finished restoring my phone to factory settings and I didn't utilize my backup file. Before the restore I didn't hv this problem.

    I'm using gmail through exchange and i hv followed all the directions given to resolve this annoying ass password issue but to no avail. I cannot get my contacts, email or calendar and I'm beyond frustrated. I hv even deleted the acct then re-added it after I did the captcha verification and turned on the two-step verification. :(:mad:

    PLEASE HELP!
     
  7. doctormusic78 macrumors newbie

    Joined:
    Feb 19, 2012
    #7
    SOLVED: Incorrect password issue after setting up a Gmail account via Exchange

    Hi all,
    I solve my issue in the following way, after a whole day of struggling:
    The Exchange password that your iPhone is asking is not your gmail account one. It's an additional password that you should generate from Google site in order to unlock their security checks. This check is required because you are trying to access Gmail not from gmail.com website but from a third-party app (in this case, Exchange on a iPhone).
    Go here:
    http://support.google.com/mail/bin/answer.py?hl=en&answer=1173270
    and follow instructions to generate that password.
    Once it is generated, write it down on paper, go on your iPhone mail settings>Exchange account, and whenever the popup appears asking for Incorrect Exchange password, insert the one written on paper.
    It worked right away for me, hope this will help :)

    Riccardo
    ---
    iPhone 3G
    iOS 4
    ...
     
  8. Matth3w macrumors regular

    Joined:
    Mar 24, 2008
    #8
    I am trying to get this set up for a friend's wife. She has iOS 5.1. I have tried everything in this thread and it doesn't work. I did it on my phone with MY gmail and it works fine. With her gmail on her phone it doesn't work. We did the verification code and it didn't work either. We set everything up just the way it is on my phone which is running 5.01.Again everything is identical. The password is correct as she logged in both the iPhone and my computer and it went right in. We also tried clearing the captcha also suggested in this thread and it says it's cleared and you have 10 minutes to log in, and it still doesn't work.

    I tried putting in the random password with spaces and without, no luck either.

    Is it an issue with 5.1???
     
  9. jabbawok macrumors regular

    jabbawok

    Joined:
    Sep 30, 2004
    Location:
    Worcestershire
    #9
    Thanks!
     
  10. Juarez7514 macrumors member

    Joined:
    Mar 17, 2009
    #10
    Worked for me. The link that doctor provided works. Thanks doc
     

Share This Page