iPhone keeps lighting up; displays message: "This accessory does not...Airplane Mode"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MacBoucher, Aug 29, 2008.

  1. MacBoucher macrumors member

    MacBoucher

    Joined:
    Jun 16, 2008
    Location:
    New Hampshire Seacoast
    #1
    My iPhone (non 3G, but with latest 2.0.2) will be laying on the table and every 5 minutes or so - it lights up to wallpaper with a message that says, "This Accessory does not work with Airplane Mode Do you want to turn Airplane Mode on?" And 95% of the time, the message goes away before you can respond, but it keeps popping up! It is draining my battery and I don't even have PUSH turned on. This is my 4th iPhone due to other problems, I hope this can be fixed and I don't have to go back tot eh Genius Bar a 5th time.

    Please help. :)
     
  2. ucsdmac macrumors 6502

    ucsdmac

    Joined:
    Jan 28, 2008
    #2
    bump..cause i'm having the same annoying problem

    Also,the external speaker makes no sound. I do not get any sound when I unlock the phone (the little click), no sound when I input text in a text message, no sound when I play a song in ipod mode. The only time I get sound from the external speaker is when someone calls me - the ringtone works fine.

    I get the "Accessory is not made to work with iPhone...Do you want to turn on airplane mode?" message every 10 seconds. It's ridiculous. Whenever I unlock it, I get that message. After undocking it, I get the message. Nothing is plugged into the iPhone, not even the dock or the headphones and it will pop up this message.


    I have tried doing a restore, tried hard reseting, checked all the relevant settings and I cannot figure out how to fix this problem. Hopefully someone can help me out here, it's very frustrating.

    Thanks
     
  3. jsep macrumors member

    Joined:
    Jul 28, 2008
    Location:
    Carlsbad, CA
    #3
    I just started getting this same problem today. I have no idea what caused it and I have no idea how to fix it. It's so annoying. Going to the apple store about it tomorrow.

    1st Gen iPhone with 2.0.2 software.
     
  4. ucsdmac macrumors 6502

    ucsdmac

    Joined:
    Jan 28, 2008
    #4
    let me know what they say...lets hope theres a quick fix for it beside replacement.
     
  5. marvisfrazier macrumors newbie

    Joined:
    Jun 13, 2008
    #5
    found a solution on apple.com discussion boards

    I followed the instructions-used "MobileFinder" instead of "File Browser" and instead of deleting the file, I simply renamed it. No more "This accessory..." messages so far.....

    Hurray!! atlast I found a soft fix for this problem!!
    After searching all the blogs for the solution.. I found nothing..
    I hv done some R&D on this and came up with a solution...
    The dig for this problem starts from finding the process in which this is causing and killing it.
    fortunately I got an application in the installer which shows all the processes that are running in iphone.
    The application is 'Sysinfo'..
    You ppl don't need to install this.. as i'm having the cause that is affecting this problem.
    Ok no more researches...
    Please follow the steps to get rid of this vague message.
    1. From Installer, Please install the "File Browser" from the 'Productivity' Category.
    2. After successfull installation of File Browser, navigate to the following path
    "/System/Library/Frameworks/IAP.framewo rk/Support/"
    (Default path the file browser will show is "/var/root". Need to change this to the above path. For
    navigating that, you need to change the settings by clicking on Settings(in File Browser app) and change
    the Home Directory in Advanced Settings from '/var/root' to '/')
    3. Now you can see a file which starts with 'apd' in the path.
    4. Select the file, click on Edit in the bottom and select Delete.
    5. Repeat the Delete untill it deletes the file.
    6. Now restart your iphone after deleting the file.
    Your phone is now free with that message and it will back you all ur features. I'm sure it won't create you
    any other problems.
    contact me to my mailid funnysuresh@gmail.com if u hv any queries...
     
  6. esoteric311 macrumors newbie

    Joined:
    Jan 8, 2009
    #6
    I just got this problem two days ago, exactly as you describe it. It was killing my battery too which ticks me off since i need my phone all day and it was dead by lunch.

    I took it to the apple store and within 5 min i had an answer as to why it was happening and it was fixed. and even though it was fixed they offered me a new one. I hate apple and the apple store, but for once they came through for me.


    the problem is this. your dock input is more than likely corroded. that was my issues he cleaned it up and it stopped. the corrosion was bridging the circuit making it think for a split second a device was connected when it was not.

    i cant believe you have been to the store 4 times with no one offering this solution.
     
  7. shinbo macrumors newbie

    Joined:
    Aug 9, 2008
    #7
    Any idea what they did to fix it? My phone is a 1st gen jailbroken and unlocked so I doubt I will get any support from the apple store.
     
  8. NDPTAL85 macrumors newbie

    Joined:
    Jul 25, 2007
    #8
    I was having similar issues. Get some rubbing alcohol, put it on a tissue and clean the contacts with it. Don't worry alcohol isn't water so you won't short anything. Let it evaporate fully and it should be ok.
     
  9. Gina18 macrumors newbie

    Joined:
    Nov 5, 2009
    #9
    Same thing

    "Also,the external speaker makes no sound. I do not get any sound when I unlock the phone (the little click), no sound when I input text in a text message, no sound when I play a song in ipod mode. The only time I get sound from the external speaker is when someone calls me - the ringtone works fine"

    I have both of these problems and i have the new 3gs and it only started to happen the last couple weeks and the phone is 2 months old, i ve to 4 different stores and they no nothing. :mad:
     
  10. nickels macrumors member

    Joined:
    Oct 3, 2008
    #10
    My wife's iPhone used to have this issue. The iPhone would think it was docked so it would disable the sound output. You could tell because the volume buttons did nothing. I had to dock it, wait a moment, then disconnect the dock. After a few tries the volume slider started to show signs of life on the iPhone and the problem was solved.
     
  11. bradyj macrumors newbie

    Joined:
    Jan 17, 2010
    #11
    My iPhone gave me the issue described here today after my daughter spilt a drink on it. I got a hair dryer, but it on cold temp / high speed and blew on the dock connector. Within a few seconds, music started coming out of the external speaker and the warning went away.
     
  12. 99wayne99 macrumors newbie

    Joined:
    Apr 27, 2010
    #12
    SIMPLE ! Don't folow that soft garbage posted. As another person posted your connection is likely coroded and making your iphone think it's plugged in to a device. SOLUTION. Take a dry toothbrush and clean the bottom connector out. I could not believe the dirt that came out of there. Works like a charm now !!! Just don't use the toothrbrush anymore !! Use it to clean your uphlostery in your car so your not wasting a toothbrush :)
     
  13. hellodara macrumors newbie

    Joined:
    Jun 16, 2010
    #13
    OMG. thank you so much. i was freaking out about this. my mom spilled a drink on mine and even though i tried to clean it out it still started showing this msg. i cleaned it and now its playing music and no longer showing this msg.

    i thought for sure i was going to have to buy another one. thanks again.
     
  14. a1southernbelle macrumors newbie

    Joined:
    Jun 26, 2010
    #14
    Thank You So much (LOL) now I just have to replace the glass. A toothbrush? WOW:D
     

Share This Page