iphone keeps loosing wifi signal

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kaz9099, Jun 11, 2009.

  1. kaz9099 macrumors newbie

    Joined:
    Jun 11, 2009
    #1
    Hi, first post here, I got recommended this forum for help.

    My other half gave me his old iphone about a week or 2 ago. Wifi always worked fine up until yesterday evening.
    It will not pick it up at all. I have deleted the wifi then reconnected it again, and still nothing.
    When i leave the iphone alone for a bit, ill look at it, and wifi has connected again, but as soon as i pick the phone up, it has disconnected again.
    When I go onto settings, it does say that it is connected.
    I googled it, and the only thing that works is turning it onto airplane mode, then back off again, and it gets wifi for about 1 or 2minutes before it stops working again.
    Hope ive given enough information, and would love it if someone can tell me how to fix it!
    Karen.
     
  2. sassy404 macrumors member

    Joined:
    Jun 14, 2009
    #2
    iphone keeps loosing wifi signal

    I'm having the same problem, and it's so frustrating.
    Please has anybody got any idea what the problem is? Is it a hardware issue.

    Help someone please :mad:
     
  3. AppleDudeAxion macrumors newbie

    AppleDudeAxion

    Joined:
    Feb 15, 2009
    Location:
    Phila, Pa
    #3
    Try going to your settings then scroll down to general. tap that then go down to where you see reset tap on that. Now in the reset section tap RESET NETWORK SETTINGS. that worked for me. you will not lose any data on your iphone as long as you only tap RESET NETWORK SETTINGS! and after your phone restarts you should be good to go. hope this works for you
     
  4. sassy404 macrumors member

    Joined:
    Jun 14, 2009
    #4
    iphone keeps loosing wifi signal

    Many thanks for the reply, but unfortunately it hasn't worked work for me.
    Hope someone else can come up with something else to try.
     
  5. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #5
    I'd suggest restoring your phone and seeing if that fixes it.
     
  6. kaz9099 thread starter macrumors newbie

    Joined:
    Jun 11, 2009
    #6
    resetting network settings didnt work
    Restored the phone, didnt work

    Realised that a random ip keeps coming up, instead of my house ip.
    Everytime i put in the right ip, and go out of the settings, it just jumps to that random ip again.
    Googled it, and others have had the problem with the ip thing too.
    Dont know what to do.
     
  7. kaz9099 thread starter macrumors newbie

    Joined:
    Jun 11, 2009
    #7
    O, and my other half has the 3g iphone, mine is 2g, and his works perfectly fine.
     

Share This Page